Bug 904702 - TypeError: not enough arguments for format string
TypeError: not enough arguments for format string
Status: CLOSED DUPLICATE of bug 885139
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:e534de7fc8bd341d9487ffca144...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-27 01:20 EST by Larry O'Leary
Modified: 2013-01-29 10:43 EST (History)
9 users (show)

See Also:
Fixed In Version: yum-3.4.3-48.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-29 10:43:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (279.81 KB, text/plain)
2013-01-27 01:20 EST, Larry O'Leary
no flags Details
File: anaconda.log (12.90 KB, text/plain)
2013-01-27 01:20 EST, Larry O'Leary
no flags Details
File: environ (1.07 KB, text/plain)
2013-01-27 01:20 EST, Larry O'Leary
no flags Details
File: ifcfg.log (544 bytes, text/plain)
2013-01-27 01:20 EST, Larry O'Leary
no flags Details
File: ks.cfg (7.34 KB, text/plain)
2013-01-27 01:20 EST, Larry O'Leary
no flags Details
File: packaging.log (14.46 KB, text/plain)
2013-01-27 01:20 EST, Larry O'Leary
no flags Details
File: program.log (31.93 KB, text/plain)
2013-01-27 01:20 EST, Larry O'Leary
no flags Details
File: storage.log (84.99 KB, text/plain)
2013-01-27 01:20 EST, Larry O'Leary
no flags Details
File: syslog (56.69 KB, text/plain)
2013-01-27 01:20 EST, Larry O'Leary
no flags Details

  None (edit)
Description Larry O'Leary 2013-01-27 01:20:04 EST
Description of problem:
I was attempting to do a Kickstart install. I had received many error messages regarding missing packages. From the looks of it, the repo lines in the Kickstart file were not getting used. In any event, I continued with the installation. I then received an error stating that @base didn't exist and shortly after that, this error occurred.
The following was filed automatically by anaconda:
anaconda 18.37.11 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/logging/__init__.py", line 328, in getMessage
    msg = msg % self.args
  File "/usr/lib64/python2.7/logging/__init__.py", line 464, in format
    record.message = record.getMessage()
  File "/usr/lib64/python2.7/logging/__init__.py", line 723, in format
    return fmt.format(record)
  File "/usr/lib64/python2.7/logging/handlers.py", line 791, in emit
    msg = self.format(record) + '\000'
  File "/usr/lib64/python2.7/site-packages/pyanaconda/anaconda_log.py", line 114, in emit
    SysLogHandler.emit(self, record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 748, in handle
    self.emit(record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 1308, in callHandlers
    hdlr.handle(record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 1268, in handle
    self.callHandlers(record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 1258, in _log
    self.handle(record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 1184, in critical
    self._log(CRITICAL, msg, args, **kwargs)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 3693, in selectGroup
    self.logger.critical(_('Group %s does have %u conditional packages, which may get installed.'), count_cond_test)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1070, in _selectYumGroup
    self._yum.selectGroup(groupid, group_package_types=pkg_types)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1198, in _applyYumSelections
    self._selectYumGroup(group.name, default=default, optional=optional)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1229, in checkSoftwareSelection
    self._applyYumSelections()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1316, in preInstall
    self.checkSoftwareSelection()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 124, in doInstall
    payload.preInstall(packages=packages, groups=payload.languageGroups(ksdata.lang.lang))
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
    threading.Thread.run(self, *args, **kwargs)
TypeError: not enough arguments for format string

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   repo=http://download.fedoraproject.org/pub/fedora/linux/releases/18/Fedora/x86_64/os/ initrd=http://download.fedoraproject.org/pub/fedora/linux/releases/18/Fedora/x86_64/os/images/pxeboot/initrd.img ks=http://home01.oleary.home/ks/base.ks BOOT_IMAGE=http://download.fedoraproject.org/pub/fedora/linux/releases/18/Fedora/x86_64/os/images/pxeboot/vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.6.10-4.fc18.x86_64
other involved packages: 
package:        anaconda-18.37.11
product:        Fedora
release:        Cannot get release name.
type:           libreport
version:        18
Comment 1 Larry O'Leary 2013-01-27 01:20:11 EST
Created attachment 688293 [details]
File: anaconda-tb
Comment 2 Larry O'Leary 2013-01-27 01:20:13 EST
Created attachment 688294 [details]
File: anaconda.log
Comment 3 Larry O'Leary 2013-01-27 01:20:14 EST
Created attachment 688295 [details]
File: environ
Comment 4 Larry O'Leary 2013-01-27 01:20:16 EST
Created attachment 688296 [details]
File: ifcfg.log
Comment 5 Larry O'Leary 2013-01-27 01:20:18 EST
Created attachment 688297 [details]
File: ks.cfg
Comment 6 Larry O'Leary 2013-01-27 01:20:21 EST
Created attachment 688298 [details]
File: packaging.log
Comment 7 Larry O'Leary 2013-01-27 01:20:23 EST
Created attachment 688299 [details]
File: program.log
Comment 8 Larry O'Leary 2013-01-27 01:20:25 EST
Created attachment 688300 [details]
File: storage.log
Comment 9 Larry O'Leary 2013-01-27 01:20:28 EST
Created attachment 688301 [details]
File: syslog
Comment 10 Larry O'Leary 2013-01-27 02:30:29 EST
Even after removing the offending package names and groups and disabling all the repo definitions in my Kickstart file, the same error occurs.

Not sure what it triggering it at this point but it does seem like Kickstart might be partially broken in Fedora 18.
Comment 11 Zdeněk Pavlas 2013-01-29 10:43:56 EST

*** This bug has been marked as a duplicate of bug 885139 ***

Note You need to log in before you can comment on or make changes to this bug.