Bug 904713 - RFE : 8021q module should be loaded by nova when using nova.network.manager.VlanManager
RFE : 8021q module should be loaded by nova when using nova.network.manager.V...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: RHOS Maint
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-27 03:59 EST by Ofer Blaut
Modified: 2013-02-12 11:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-12 11:50:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ofer Blaut 2013-01-27 03:59:51 EST
Description of problem:

When nova is using nova.network.manager.VlanManager

module 8021q must be used.

currently it is up to user to add it manually ( modprobe 8021q )

Since nova build :
1. linux bridge 
2. vlan 
3. and its interface 

, it should also load the module.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Russell Bryant 2013-02-12 11:50:34 EST
I feel that loading kernel modules is outside the scope of what nova should be doing.

Note You need to log in before you can comment on or make changes to this bug.