Bug 90473 - impossible to disable php in directory
Summary: impossible to disable php in directory
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-08 19:07 UTC by Need Real Name
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-25 16:46:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2003-05-08 19:07:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)

Description of problem:
Is impossible disable php script execution
in some directories on webserver

Version-Release number of selected component (if applicable):
httpd-2.0.40-21.1 php-4.2.2-17

How reproducible:
Always

Steps to Reproduce:
1. key sections from webserver configuration :
    <Directory "/home/httpd/html">
       AllowOverride AuthConfig Limit
       Order allow,deny
       Allow from all
    </Directory>
    <Directory "/home/httpd/html/nophp/">
       php_flag engine off
       php_admin_flag engine off
       php_value engine 0
       php_admin_value engine 0
    </Directory>
    <Directory "/home/httpd/html/nophp">
       php_flag engine off
       php_admin_flag engine off
       php_value engine 0
       php_admin_value engine 0
    </Directory>

2. in /home/httpd/html/nophp is file x.php and contains :
  <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
  <HTML>
  <HEAD>
     <TITLE>Test PHP</TITLE>
  </HEAD>
  <BODY>
  <?
   $DATUM = date("YmdHis",time());
   echo "Date $DATUM <BR>";
   echo "<BR>";
  ?>
  </BODY>
  </HTML>


Actual Results:  access the script /nophp/x.php on webserver produce 
proper output - Date 20030508205402 - on the page.


Expected Results:  nothing to display and page source must contain :

 <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN"> 
 <HTML>
 <HEAD>
   <TITLE>Test PHP</TITLE>
 </HEAD>
 <BODY>
 <?
 $DATUM = date("YmdHis",time());
 echo "Date $DATUM <BR>";
 echo "<BR>";
 ?>
 </BODY>
 </HTML>

Comment 1 Joe Orton 2003-07-07 13:49:19 UTC
Thanks for the report.

Comment 2 Joe Orton 2005-01-25 16:46:47 UTC
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

c) report the bug to the Fedora Legacy project who may wish to
continue maintenance of this package.



Note You need to log in before you can comment on or make changes to this bug.