Bug 904751 - Two instances with same FIXED IP
Two instances with same FIXED IP
Status: CLOSED WORKSFORME
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
unspecified Severity high
: async
: 2.1
Assigned To: Brent Eagles
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-27 06:35 EST by Ofer Blaut
Modified: 2016-04-26 13:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-27 03:39:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
two VMs with same ip 13.77.77.3 & 13.77.77.4 (17.10 KB, text/plain)
2013-01-27 06:35 EST, Ofer Blaut
no flags Details

  None (edit)
Description Ofer Blaut 2013-01-27 06:35:03 EST
Created attachment 688389 [details]
two VMs with same ip 13.77.77.3 & 13.77.77.4

Description of problem:

Launcing VMs both by nova CLI and Horizon, i encounter state where few instances share same fixed ip ( see exmaples attached with 13.77.77.3 & 13.77.77.4)

Version-Release number of selected component (if applicable):



How reproducible:


Steps to Reproduce:
1. launch few VMs both from nova CLI and Horizon ( not sure it heppnes all the time )
2.check nova list 
3.wait few minutes and check nova list again 
  
Actual results:


Expected results:


Additional info:
Comment 2 Brent Eagles 2013-02-14 18:33:12 EST
After several attempts, I have been unable to reproduce this issue. Are there other variables not listed here? For example:

* Multiple compute nodes
* Multiple network nodes
* Nested VMs (compute, network, etc running in VMs)
Comment 3 Ofer Blaut 2013-02-15 03:53:58 EST
I was using two compute nodes .
one of the compute nodes act as nova network & compute node, the other doesn't have nova network.
no Netsted VMs
Comment 4 Brent Eagles 2013-02-26 13:58:24 EST
I was unable to reproduce using a configuration similar to the one described. If it is easy to reproduce or recurs, please provide the following information:

- nova.conf files for both compute nodes
- compute and network log files for the relevant period (e.g in your attachment, the first entry is 10:48:36 and the second is 11:17:52)
- the output of nova show 'instance id' for each of the instances

If it recurs, would it be possible to get access to the system? 

Thanks.
Comment 5 Ofer Blaut 2013-02-27 03:39:09 EST
Issue is not reproduced on build openstack-nova-network-2012.2.3-1.el6ost.noarch

Note You need to log in before you can comment on or make changes to this bug.