This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 90476 - Double Sided Printing -- Off does not work
Double Sided Printing -- Off does not work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-08 15:26 EDT by John Velman
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-26 09:48:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Velman 2003-05-08 15:26:14 EDT
Description of problem:
Editing the printer driver settings, and selecting double sided printing options
--  no matter which option is checked, the printer prints as though "short edge
(flipped)" were checked.

Print driver is hpijs for HP 940c

Unable to achieve single sided printing.  Every other page is flipped, and
always prints a blank page at the end for any document having an odd number of
pages.


Version-Release number of selected component (if applicable):

New boxed set of RH 9.  Unfortunately, the application does not have an 'about'
selection that gives the version and release number.

How reproducible:

Every time.


Steps to Reproduce:
1. Edit driver properties
2. In properties, for Double-sided printing, select "Off"
3. Save, apply
4. Print document with odd number of pages
    
Actual results:

Even numbered pages are printed upside down.  Extra blank page is printed
at the end:  I.e., when document has 1 page, two pages come out of printer; when
document has 3 pages, 4 pages come out of the printer,...


Expected results:

All pages printed right side up.  1 page printed with no extras when document
has one page.  and so on.

Additional info:
Comment 1 Tim Waugh 2003-05-09 04:21:27 EDT
Please could you attach the output of 'printconf-tui --Xexport'?  Thanks.
Comment 2 John Velman 2003-05-09 11:44:45 EDT
As requested, here is the output of 'printconf-tui --Xexport':

<?xml version="1.0"?>
<adm_context VERSION="0">
  <id NAME="local" SERIAL="1052331297">
    <null/>
    <null/>
    </id>
  <datatree>
    <printconf TYPE="LIST">
      <print_queues TYPE="LIST">
        <cdj ATOMIC="TRUE" TYPE="LIST">
          <alias_list ANONYMOUS="TRUE" TYPE="LIST">
            </alias_list>
          <queue_type TYPE="STRING" VALUE="LOCAL"/>
          <queue_data TYPE="LIST">
            <local_printer_device TYPE="STRING" VALUE="/dev/lp0"/>
            </queue_data>
          <filter_data TYPE="LIST">
            <print_header_page TYPE="BOOL" VALUE="FALSE"/>
            <flags TYPE="LIST">
              <rerender_Postscript TYPE="BOOL" VALUE="FALSE"/>
              <convert_text_to_Postscript TYPE="BOOL" VALUE="TRUE"/>
              <send_FF TYPE="BOOL" VALUE="FALSE"/>
              <assume_data_is_text TYPE="BOOL" VALUE="FALSE"/>
              <send_EOT TYPE="BOOL" VALUE="FALSE"/>
              </flags>
            <mf_type TYPE="STRING" VALUE="MFOMATIC"/>
            <filter_locale TYPE="STRING" VALUE="C"/>
            <printer_id TYPE="STRING" VALUE="HP-DeskJet_940C"/>
            <gs_driver TYPE="STRING" VALUE="hpijs"/>
            <foomatic_defaults ANONYMOUS="TRUE" TYPE="LIST">
              </foomatic_defaults>
            </filter_data>
          <filter_type TYPE="STRING" VALUE="MAGICFILTER"/>
          <queue_description TYPE="STRING" VALUE=""/>
          <jobsheets TYPE="LIST">
            <start TYPE="STRING" VALUE="none"/>
            <end TYPE="STRING" VALUE="none"/>
            </jobsheets>
          <margins TYPE="LIST">
            <top TYPE="INT" VALUE="36"/>
            <right TYPE="INT" VALUE="36"/>
            <bottom TYPE="INT" VALUE="36"/>
            <left TYPE="INT" VALUE="36"/>
            </margins>
          <lpoptions TYPE="LIST">
            </lpoptions>
          </cdj>
        <mdj ATOMIC="TRUE" TYPE="LIST">
          <alias_list ANONYMOUS="TRUE" TYPE="LIST">
            </alias_list>
          <queue_type TYPE="STRING" VALUE="LOCAL"/>
          <queue_data TYPE="LIST">
            <local_printer_device TYPE="STRING" VALUE="/dev/lp0"/>
            </queue_data>
          <filter_data TYPE="LIST">
            <print_header_page TYPE="BOOL" VALUE="FALSE"/>
            <flags TYPE="LIST">
              <send_FF TYPE="BOOL" VALUE="FALSE"/>
              <convert_text_to_Postscript TYPE="BOOL" VALUE="TRUE"/>
              <rerender_Postscript TYPE="BOOL" VALUE="FALSE"/>
              <assume_data_is_text TYPE="BOOL" VALUE="FALSE"/>
              <send_EOT TYPE="BOOL" VALUE="FALSE"/>
              </flags>
            <mf_type TYPE="STRING" VALUE="MFOMATIC"/>
            <filter_locale TYPE="STRING" VALUE="C"/>
            <printer_id TYPE="STRING" VALUE="HP-DeskJet_940C"/>
            <gs_driver TYPE="STRING" VALUE="hpijs"/>
            <foomatic_defaults ANONYMOUS="TRUE" TYPE="LIST">
              <option_default TYPE="LIST">
                <name TYPE="STRING" VALUE="Duplex"/>
                <type TYPE="STRING" VALUE="enum"/>
                <default TYPE="STRING" VALUE="DuplexTumble"/>
                </option_default>
              <option_default TYPE="LIST">
                <name TYPE="STRING" VALUE="Resolution"/>
                <type TYPE="STRING" VALUE="enum"/>
                <default TYPE="STRING" VALUE="300GrayscaleCMYK"/>
                </option_default>
              </foomatic_defaults>
            </filter_data>
          <filter_type TYPE="STRING" VALUE="MAGICFILTER"/>
          <queue_description TYPE="STRING" VALUE=""/>
          <jobsheets TYPE="LIST">
            <start TYPE="STRING" VALUE="none"/>
            <end TYPE="STRING" VALUE="none"/>
            </jobsheets>
          <margins TYPE="LIST">
            <top TYPE="INT" VALUE="36"/>
            <right TYPE="INT" VALUE="36"/>
            <bottom TYPE="INT" VALUE="36"/>
            <left TYPE="INT" VALUE="36"/>
            </margins>
          <lpoptions TYPE="LIST">
            </lpoptions>
          </mdj>
        </print_queues>
      <default_queue TYPE="STRING" VALUE="mdj"/>
      </printconf>
    </datatree>
  </adm_context>
Comment 3 Tim Waugh 2003-05-12 06:45:59 EDT
Are you using the 'cdj' queue, or the 'mdj' queue?  The mdj queue seems to have
duplex set, but the cdj one doesn't.
Comment 4 John Velman 2003-05-15 15:47:07 EDT
Sorry to take so long to get back.  Been dealing with other problems.

O.K.  This gets curiouser and curiouser.

1.  mdj is my default que.  When I checked out the printing situation yesterday
in order to respond to your message, yes, in fact mdj was set (in the printer
edit dialog box) to "two side--flip".   I changed it, did an apply, and tested
a one page printout.  Seemed to work OK.  Blew my mind, since I thought I'd
checked carefully before submitting the bug report.  Started to write a reply,
but my net connection went down.  Had to give up for the day.

That was running under LPRng printing system.

2. This I tried printing a single page, and didn't get a second blank.  Then
tried printing two pages, and it did flip the second page.  Still on LPRng.

3. Closed the printer edit application, used the redhat-switch-printer to change
 to CUPS.  

4. Verified that the printer configuration hadn't changed.  Tried printing both
long and short pages on mdj.  

--  Single line of text results in 2 pages being printed, second one blank.

-- Two pages being printed, second one is flipped.

5.  (CUPS takes an incredibly long time to start printing, by the way).
Switched back to LPRng.  Reverified that the printerconf file hadn't changed.
NOW, under LPRng, 
--  mdj prints blank page following single page output.
--  mdj flips second page on two page output.

6.  Noted that this printing was being done from within gvim, using the ha
command.

7. Converted test text file to postscript using enscript.  Printing
works OK (i.e., no extra pages, no flipping) from gv.  Both default and
lpr -P cdj commands.

8.  Tried gvim again.  still printing duplex-flip style.

9.  converted test file to pdf.  Acroread prints it OK.

10.  Tried printing text file from Galeon.  Works ok.

-- So, it appears the the problem (currently) lies somehow with gvim.

I guess it isn't necessary to say I didn't have this problem before 'upgrading'
to RH 9, but I'll say it anyway.

Here is the current output of 'printconf-tui --Xexport':

<?xml version="1.0"?>
<adm_context VERSION="0">
  <id NAME="local" SERIAL="1053022680">
    <null/>
    <null/>
    </id>
  <datatree>
    <printconf TYPE="LIST">
      <print_queues TYPE="LIST">
        <cdj ATOMIC="TRUE" TYPE="LIST">
          <alias_list ANONYMOUS="TRUE" TYPE="LIST">
            </alias_list>
          <queue_type TYPE="STRING" VALUE="LOCAL"/>
          <queue_data TYPE="LIST">
            <local_printer_device TYPE="STRING" VALUE="/dev/lp0"/>
            </queue_data>
          <filter_data TYPE="LIST">
            <print_header_page TYPE="BOOL" VALUE="FALSE"/>
            <flags TYPE="LIST">
              <rerender_Postscript TYPE="BOOL" VALUE="FALSE"/>
              <convert_text_to_Postscript TYPE="BOOL" VALUE="TRUE"/>
              <send_FF TYPE="BOOL" VALUE="FALSE"/>
              <assume_data_is_text TYPE="BOOL" VALUE="FALSE"/>
              <send_EOT TYPE="BOOL" VALUE="FALSE"/>
              </flags>
            <mf_type TYPE="STRING" VALUE="MFOMATIC"/>
            <filter_locale TYPE="STRING" VALUE="C"/>
            <printer_id TYPE="STRING" VALUE="HP-DeskJet_940C"/>
            <gs_driver TYPE="STRING" VALUE="hpijs"/>
            <foomatic_defaults ANONYMOUS="TRUE" TYPE="LIST">
              </foomatic_defaults>
            </filter_data>
          <filter_type TYPE="STRING" VALUE="MAGICFILTER"/>
          <queue_description TYPE="STRING" VALUE=""/>
          <jobsheets TYPE="LIST">
            <start TYPE="STRING" VALUE="none"/>
            <end TYPE="STRING" VALUE="none"/>
            </jobsheets>
          <margins TYPE="LIST">
            <top TYPE="INT" VALUE="36"/>
            <right TYPE="INT" VALUE="36"/>
            <bottom TYPE="INT" VALUE="36"/>
            <left TYPE="INT" VALUE="36"/>
            </margins>
          <lpoptions TYPE="LIST">
            </lpoptions>
          </cdj>
        <mdj ATOMIC="TRUE" TYPE="LIST">
          <alias_list ANONYMOUS="TRUE" TYPE="LIST">
            </alias_list>
          <queue_type TYPE="STRING" VALUE="LOCAL"/>
          <queue_data TYPE="LIST">
            <local_printer_device TYPE="STRING" VALUE="/dev/lp0"/>
            </queue_data>
          <filter_data TYPE="LIST">
            <print_header_page TYPE="BOOL" VALUE="FALSE"/>
            <flags TYPE="LIST">
              <rerender_Postscript TYPE="BOOL" VALUE="FALSE"/>
              <convert_text_to_Postscript TYPE="BOOL" VALUE="TRUE"/>
              <send_FF TYPE="BOOL" VALUE="FALSE"/>
              <assume_data_is_text TYPE="BOOL" VALUE="FALSE"/>
              <send_EOT TYPE="BOOL" VALUE="FALSE"/>
              </flags>
            <mf_type TYPE="STRING" VALUE="MFOMATIC"/>
            <filter_locale TYPE="STRING" VALUE="C"/>
            <printer_id TYPE="STRING" VALUE="HP-DeskJet_940C"/>
            <gs_driver TYPE="STRING" VALUE="hpijs"/>
            <foomatic_defaults ANONYMOUS="TRUE" TYPE="LIST">
              <option_default TYPE="LIST">
                <name TYPE="STRING" VALUE="Resolution"/>
                <type TYPE="STRING" VALUE="enum"/>
                <default TYPE="STRING" VALUE="300GrayscaleCMYK"/>
                </option_default>
              </foomatic_defaults>
            </filter_data>
          <filter_type TYPE="STRING" VALUE="MAGICFILTER"/>
          <queue_description TYPE="STRING" VALUE=""/>
          <jobsheets TYPE="LIST">
            <start TYPE="STRING" VALUE="none"/>
            <end TYPE="STRING" VALUE="none"/>
            </jobsheets>
          <margins TYPE="LIST">
            <top TYPE="INT" VALUE="36"/>
            <right TYPE="INT" VALUE="36"/>
            <bottom TYPE="INT" VALUE="36"/>
            <left TYPE="INT" VALUE="36"/>
            </margins>
          <lpoptions TYPE="LIST">
            </lpoptions>
          </mdj>
        </print_queues>
      <default_queue TYPE="STRING" VALUE="mdj"/>
      </printconf>
    </datatree>
  </adm_context>





Comment 5 John Velman 2003-05-15 16:42:42 EDT
Looks like the problem is in the default options of vim (gvim) -- at
least it looks that way at the moment.

I explicitly set the printoptions of gvim for duplex:off, and now printing
from gvim works properly.

Apparently something changed in the default setting of the vim versions
distributed with 7.2 and 9 -- or else the new printer driver allowed them to
work differently, or else?

Well, it looks like my printing problem is taken care of.

Thanks.

John V.
Comment 6 Tim Waugh 2003-05-15 18:01:18 EDT
Changing component to vim and reassigning.  Thanks for investigating it.
Comment 7 Karsten Hopp 2005-01-26 09:48:45 EST
fixed in current versions

Note You need to log in before you can comment on or make changes to this bug.