Bug 904762 - rhevm-config: we are not asking to confirm new password when changing internal user's password
rhevm-config: we are not asking to confirm new password when changing interna...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-config (Show other bugs)
3.1.2
x86_64 Linux
unspecified Severity high
: ---
: 3.2.0
Assigned To: Ravi Nori
Pavel Stehlik
infra
:
: 851102 (view as bug list)
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2013-01-27 07:36 EST by Dafna Ron
Modified: 2016-02-10 14:24 EST (History)
9 users (show)

See Also:
Fixed In Version: sf7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine-config log (5.73 KB, application/x-xz)
2013-01-27 07:36 EST, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11817 None None None Never

  None (edit)
Description Dafna Ron 2013-01-27 07:36:26 EST
Created attachment 688415 [details]
engine-config log

Description of problem:

when changing the internal user's password we are not asked to confirm the new password or give the old one first. 

Version-Release number of selected component (if applicable):

si26.1

How reproducible:

100%

Steps to Reproduce:
1. run 'rhevm-config -s AdminPassword=interactive'
2.
3.
  
Actual results:

we are not asked for old password
we are not asked to confirm the new password

Expected results:

we should confirm the old password and we should ask for the new password twice to confirm (even root user passwd will require this). 

Additional info:

[root@daffi-linux ~]# rhevm-config -s AdminPassword=interactive
Please enter a password
[root@daffi-linux ~]#
Comment 2 Ravi Nori 2013-02-25 13:39:48 EST
*** Bug 851102 has been marked as a duplicate of this bug. ***
Comment 3 Oded Ramraz 2013-03-03 14:45:50 EST
[root@aqua-rhel yum.repos.d]# rhevm-config -s AdminPassword=interactive
Please enter a password
Please reenter password

( maybe it would be better to change it to re-enter )

Verified sf9
Comment 4 Marina 2013-03-29 18:37:00 EDT
I think it should say:
"Please enter new password".

When you use the command first time, it is very confusing - what password to enter - current or new one?

Should I reopen this bug? Would be nice having it fix.
Comment 5 Itamar Heim 2013-06-11 05:49:55 EDT
3.2 has been released
Comment 6 Itamar Heim 2013-06-11 05:49:57 EDT
3.2 has been released
Comment 7 Itamar Heim 2013-06-11 05:57:56 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.