Bug 904842 - Add nic with unused MAC to VM fails when adding it earlier failed for some reason - MAC address is not freed
Add nic with unused MAC to VM fails when adding it earlier failed for some re...
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
unspecified
x86_64 All
medium Severity high
: ---
: 3.2.0
Assigned To: Muli Salem
Meni Yakove
network
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-27 15:15 EST by Meni Yakove
Modified: 2016-02-10 14:47 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 04:56:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
engine.log (3.61 MB, application/octet-stream)
2013-01-27 15:15 EST, Meni Yakove
no flags Details

  None (edit)
Description Meni Yakove 2013-01-27 15:15:35 EST
Created attachment 688599 [details]
engine.log

Description of problem:
When adding nic to VM and the add operation fails the MAC address from the failed add nic cannot be used again.

Version-Release number of selected component (if applicable):
rhevm-3.2.0-5.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1.Create VM with 1 nic and start the VM
2.while the VM is up hot-unplug the nic and change the MAC address (one operation)> should fail > Bug 904840
3.Create a new nic with the same MAC address from step 2.
  
Actual results:
Fail with error MAC Address is already in use.

Expected results:
MAC address should be free and can add to new nic.
Comment 2 Simon Grinberg 2013-02-28 04:56:13 EST
This scenario is really a corner case on other bugs since there is no reason to fix it, what should be fixed are the scenarios that caused MAC change to fail.

Note You need to log in before you can comment on or make changes to this bug.