Bug 904897 - [docx] writer fails to save any text following a hyperlink on export to docx
[docx] writer fails to save any text following a hyperlink on export to docx
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-27 22:46 EST by John
Modified: 2013-04-01 18:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-01 18:26:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Good ODT file. (10.58 KB, application/vnd.oasis.opendocument.text)
2013-01-27 22:46 EST, John
no flags Details

  None (edit)
Description John 2013-01-27 22:46:56 EST
Created attachment 688735 [details]
Good ODT file.

Description of problem:
When editing a docx formated file, inserting a hyperlink with a pound sign (#) causes everything after the hyperlink to vanish after saving, closing, and reopening the file. 

Version-Release number of selected component (if applicable):
3.5.7.2

How reproducible:
Always

Steps to Reproduce:
1.Create or save a file in docx format.
2.Insert a hyperlink with a pound sign into the document. For example, simply copy and paste the following link into a document: http://windows.microsoft.com/en-US/windows/service-packs-download#sptabs=win8
3.Enter more text after the hyperlink.
4.Save the document.
5.Close the document.
6.Open the document.
  
Actual results:
Any text entered after the hyperlink is not saved even though LOWriter seems to be saving everything. In addition, the hyperlink is either truncated by one character or entirely deleted. Each subsequent save will truncate the link one additional character. Any text before the hyperlink is retained.

Expected results:
Everything in the document should be saved.

Additional info: Seems not to be an issue when using the odt format. Try saving the attached odt file as docx to see the issue in action. Remember to close it and reopen it to see the effect.
Comment 1 David Tardon 2013-01-31 09:05:23 EST
Seems to be fixed in 3.6. Because it is a data loss, I am going to find and backport the fix.
Comment 2 Fedora Update System 2013-03-23 09:33:08 EDT
libreoffice-3.5.7.2-10.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libreoffice-3.5.7.2-10.fc17
Comment 3 Fedora Update System 2013-03-23 20:05:26 EDT
Package libreoffice-3.5.7.2-10.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.5.7.2-10.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-4337/libreoffice-3.5.7.2-10.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-04-01 18:27:00 EDT
libreoffice-3.5.7.2-10.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.