Bug 904978 - Missing libicu-48 dependency for Gnome 3.6 after F17->F18 upgrade
Missing libicu-48 dependency for Gnome 3.6 after F17->F18 upgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-28 05:30 EST by Dmitry Glavchev
Modified: 2013-01-28 09:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-28 09:07:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dmitry Glavchev 2013-01-28 05:30:12 EST
I've been trying to revive my Lenovo X201 after F17->F18 upgrade (fedup-based) since Xorg falied to start. Finally I've located gdm error message saying libicuuc.so.48 is missing. Xorg was ok.

F18 has libicu package version 49. Finally ldd gnome-terminal gave me this:

	libicuuc.so.48 => /lib64/libicuuc.so.48 (0x00007f7f5d70a000)
	libicudata.so.48 => /lib64/libicudata.so.48 (0x00007f7f5c3e9000)

They were in "not found" state, now these 2 files are just symlinks to version 49 libs which is not too elegant. But finally Xorg with Gnome started and everything worked pretty good until I've tried to start python-gtk helloworld app which uses gtk bindings. It failed to start saying:

       ImportError: /lib64/libharfbuzz.so.0: undefined symbol: uscript_getShortName_48

Obviously some intermediate library (libharfbuzz is this case) requires real icu 48, not fake one.

I've resolved this issue by extracting .so files from package libicu-4.8.1.1-2.fc17.x86_64.rpm and placing them into /lib64, now F18 looks fully working for me - but I think it's quite ridiculous solution.

Looks like there are a lot of software linked to icu-48 thus I suppose it would be great to add libicu-48 to "fedora" repository to allow yum downgrade.

Not sure if I can fully reproduce this rolling back to 17 and upgrading once more - but if I remove v48 libs, system will be broken again.
Comment 1 Dmitry Glavchev 2013-01-28 05:35:04 EST
missing dependency is across all gnome binaries: gedit, gnome-session, gcalctool etc. Looks like initial GDM start problem was due to failed gnome-session.
Comment 2 Dmitry Glavchev 2013-01-28 09:07:45 EST
sorry, environmental issue

Note You need to log in before you can comment on or make changes to this bug.