Bug 90500 - Hebrew unicode section of Nimbus Mono L is broken
Hebrew unicode section of Nimbus Mono L is broken
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: urw-fonts (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-08 17:32 EDT by Dov Grobgeld
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-12 17:44:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dov Grobgeld 2003-05-08 17:32:56 EDT
Description of problem:

The font "Nimbus Mono L" included in RH9 only defines the first 16 characters of
the Hebrew alphabet (which contains 26 characters including the final forms)
starting at U+05D0. If this font is chosen for the display of Hebrew text
through fontconfig the result looks very strange, as part of the text will be
shown in part Nimbus Mono L and part in some other fallback font.

This property of the font may be verified e.g. by pfaedit or by gucharmap.

What is interesting is that the bold, the italic, and the bold-italic versions
of these fonts don't define the Hebrew unicode section at all. I think the
correct solution is to erase the Hebrew glyphs from the font alltogether, as the
 Hebrew glyphs anyhow are butt ugly.

Version-Release number of selected component (if applicable):

urw-fonts-2.0-29

How reproducible:

Everytime

Steps to Reproduce:
1. run gedit
2. change the font to Nimbus mono L
3. Paste the sequence of the Hebrew alphabet into gedit:

    אבגדהוזחטיכלמןסעפרקרשת
    
Actual results:

    The text is shown in two different fonts

Expected results:

    One font

Additional info:
Comment 1 Owen Taylor 2003-06-12 17:44:57 EDT
Seems to be fixed in 2.1 that has a newer upstream version of the 
urw fonts.

Note You need to log in before you can comment on or make changes to this bug.