This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 905038 - vdsm: when delete of volume fails we can still see the volume in getImagesList
vdsm: when delete of volume fails we can still see the volume in getImagesList
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.1.2
x86_64 Linux
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Eduardo Warszawski
Aharon Canan
storage
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-28 07:46 EST by Dafna Ron
Modified: 2016-02-10 15:26 EST (History)
11 users (show)

See Also:
Fixed In Version: is4
Doc Type: Bug Fix
Doc Text:
When deleting a volume and it failed to delete, the partially deleted image could still be seen in the images list. VDSM now ignores partially deleted images when retrieving a list of images.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:05:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (848.80 KB, application/x-gzip)
2013-01-28 07:46 EST, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 12938 None None None Never

  None (edit)
Description Dafna Ron 2013-01-28 07:46:10 EST
Created attachment 688931 [details]
logs

Description of problem:

when we delete an image we are adding remove_me tag which should remove the image from the images list. 

after vdsm failed to remove an image after vdsm restart, we can still see it when we run getImagesList on the vg. 

Version-Release number of selected component (if applicable):

vdsm-4.10.2-1.2.el6.x86_64
si26.1

How reproducible:

100%

Steps to Reproduce:
1. remove a vm
2. restart vdsm 
3. run vdsClient -s 0 getImagesList <domain>
  
Actual results:

we see the image that failed to be deleted under the list of images.  

Expected results:

we should not see the image that was failed to be deleted under the list of images.

Additional info:

[root@cougar01 ~]# vdsClient -s 0 getImagesList 9856cc2c-2c77-439f-b809-97c63000c77e
d4c6b13a-fce6-48e9-9ad3-d659a2ff568c


[root@cougar01 ~]# lvs -o vg_name,lv_name,lv_tags 9856cc2c-2c77-439f-b809-97c63000c77e
  VG                                   LV                                   LV Tags 
  9856cc2c-2c77-439f-b809-97c63000c77e 60492427-6de3-4a56-bee6-3bced79ceb7d IU_d4c6b13a-fce6-48e9-9ad3-d659a2ff568c,MD_7,PU_00000000-0000-0000-0000-000000000000,_remove_me_d4c6b13a-fce6-48e9-9ad3-d659a2ff568c
Comment 2 Eduardo Warszawski 2013-01-31 05:57:37 EST


The consequence of this bug is garbage volumes remnaining in the storage.
It can only happen if the postzeroing process is interrupted in the middle.
Potzeroing is only relevant on the blockSD realm.

Workaround:
The volumes can be easily identified by the tag and removed.


Required but not sufficient patch:
http://gerrit.ovirt.org/#/c/11593/


#vg_name,lv_name,lv_tags d4c6b13a-fce6-48e9-9ad3-d659a2ff568c

  9856cc2c-2c77-439f-b809-97c63000c77e 60492427-6de3-4a56-bee6-3bced79ceb7d IU_d4c6b13a-fce6-48e9-9ad3-d659a2ff568c,MD_7,PU_00000000-0000-0000-0000-000000000000,_remove_me_d4c6b13a-fce6-48e9-9ad3-d659a2ff568c
Comment 5 Aharon Canan 2013-07-16 13:42:11 EDT
verified using 3.3 is5
Comment 6 Charlie 2013-11-27 19:31:31 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 7 errata-xmlrpc 2014-01-21 11:05:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.