Bug 905103 - Firefox ocassionally freezes unpredictably and takes out X with it
Firefox ocassionally freezes unpredictably and takes out X with it
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
18
x86_64 All
unspecified Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-28 10:28 EST by Alexander van Loon
Modified: 2013-02-08 05:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-08 05:20:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (39.29 KB, text/x-log)
2013-02-07 11:15 EST, Alexander van Loon
no flags Details
Xorg.0.log.old (40.02 KB, application/octet-stream)
2013-02-07 11:16 EST, Alexander van Loon
no flags Details

  None (edit)
Description Alexander van Loon 2013-01-28 10:28:41 EST
Description of problem:
I'm using a fully updated Fedora 18 with Firefox. Over the last week since I started using Fedora 18 (fresh install, no upgrade) I've seen it happen two or three times that Firefox and X after it completely freeze if I click a URL which is opened by Firefox.

The mouse cursor and keyboard become unresponsive. There is no realiable way to reproduce it, but it only happens if I click a link which is then opened in Firefox. The URL which is opened doesn't seem to have any effect, last time it happened when Firefox opened http://www.werkenvoornederland.nl/ which is a legit website. On that occassion I clicked the link in an e-mail I had open in Evolution.

All I can do is hit my PC's reset button. After a reboot I don't get any error messages, only the "Oops, this is embarissing" question from Firefox if I want to restore my tabs. I did have 15 tabs or so open at the time of the crash.

In this topic – http://forums.fedoraforum.org/showthread.php?t=282221 – on FedoraForum.org others seems to describe exactly the same issue I experience, but they don't mention existing bug reports.
Comment 1 Martin Stransky 2013-02-07 09:33:30 EST
Can you please attach Xorg.0.log (and Xorg.0.log.old) log files? There should be the info about X crash.
Comment 2 Alexander van Loon 2013-02-07 11:15:25 EST
Created attachment 694578 [details]
Xorg.0.log
Comment 3 Alexander van Loon 2013-02-07 11:16:18 EST
Created attachment 694579 [details]
Xorg.0.log.old

Here you are.
Comment 4 Martin Stransky 2013-02-08 04:24:38 EST
Ahh, sorry, I mean Xorg.0.log and Xorg.0.log.old files when the Firefox crashes. A crash log should be there.
Comment 5 Alexander van Loon 2013-02-08 05:20:17 EST
Okay, I kind of expected that because I didn't read anything unusual when I uploaded the files :)

The problem is that I haven't seen a crash occur during the last one or two weeks. I guess I'll just close this bug for now and reopen it (and attach relevant X.org log files) if the crash hits me again.

Note You need to log in before you can comment on or make changes to this bug.