Bug 905115 - Backport qpid_hosts option - quantum
Backport qpid_hosts option - quantum
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-quantum (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity unspecified
: snapshot3
: 2.1
Assigned To: Gary Kotton
Ofer Blaut
: Triaged
Depends On: 905113
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-28 10:51 EST by Russell Bryant
Modified: 2016-04-26 11:40 EDT (History)
6 users (show)

See Also:
Fixed In Version: 2012.2.3-2.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 905114
Environment:
Last Closed: 2013-03-21 15:04:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 9 Ofer Blaut 2013-03-19 07:21:47 EDT
Tested openstack-quantum-2012.2.3-8.el6ost.noarch

I have configured quantum.conf with two hosts.


First IP doesn't use qpid , Second one is the real qpid 

So connecting to first qpid failed and later the second one was used.

#qpid_hostname = 10.35.160.77

qpid_hosts = 10.35.160.89:5672,10.35.160.77:5672
restarted quantum services and checked server.log


2013-03-19 13:14:28    ERROR [quantum.openstack.common.rpc.impl_qpid] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 1 seconds
2013-03-19 13:14:28    ERROR [quantum.openstack.common.rpc.impl_qpid] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 1 seconds
2013-03-19 13:14:29     INFO [quantum.openstack.common.rpc.impl_qpid] Connected to AMQP server on 10.35.160.77:5672
2013-03-19 13:14:29     INFO [quantum.openstack.common.rpc.impl_qpid] Connected to AMQP server on 10.35.160.77:5672



also tested when qpid ip is not alive on the network 

2013-03-19 13:18:23    ERROR [quantum.openstack.common.rpc.impl_qpid] Unable to connect to AMQP server: [Errno 113] EHOSTUNREACH. Sleeping 1 seconds
2013-03-19 13:18:23     INFO [quantum.openstack.common.rpc.impl_qpid] Connected to AMQP server on 10.35.160.77:5672
2013-03-19 13:18:24     INFO [quantum.openstack.common.rpc.impl_qpid] Connected to AMQP server on 10.35.160.77:5672



I did success to create subnet on quantum
Comment 11 errata-xmlrpc 2013-03-21 15:04:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0672.html

Note You need to log in before you can comment on or make changes to this bug.