Bug 90514 - Graphical configuration of users doesn't seem to work; cannot access printers via Windows
Graphical configuration of users doesn't seem to work; cannot access printers...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-samba (Show other bugs)
9
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-08 23:58 EDT by Shawn D. Kelly
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-02 20:04:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shawn D. Kelly 2003-05-08 23:58:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I've been trying to get Samba running for the past few days.  I installed RH 9
without issue, then setup my printer under CUPS and it works fine under RH 9.  I
immediately started to look into setting up Samba.

I ran the Samba Server Configuration and set the workgroup and description.  I
set the security to User, Encrypt Passwords, No Guest Account.  I went in and
then attempted to add myself as a user.  This did not add my name to the users
list.  I tried again and it told me I was already setup as a user, yet my name
still didn't show on the list.  Am I reading the instructions wrong?

After more investigation, I found the RH 9 docs for Samba on the RH site and
found that I needed to copy the passwd file to smbpasswd since I was using
Encrypted passwords, then set the password for the account from the command line.

It seems that smbpasswd is also the file used for the users list??  I went back
into the graphical configursation and all these users are listed now.  I am
confused as to this because I thought that was what smbusers was for.

Anyhow, after I turned the Firewall off (which I told RH not to turn on during
install in the first place, but thats a whole other issue) I was able to finally
see my home directory from within Windows.  Yet, I still cannot see or map to a
a printer.

I'm trying to access it from a Windows XP Pro system.  My username/password is
the same between Windows, Linux, and Samba.

The latest error I am getting in the logfile for the computer attempting to
access the printer list is:

[2003/05/08 23:06:44, 0] smbd/service.c:make_connection(252)
  optimus-prime (192.168.0.4) couldn't find service
::{2227a280-3aea-1069-a2de-08002b30309d}

I apologize if I sound a bit flakey right now... I'm tired and want to get this
fired off before bed.  If you need anymore information, please let me know.

*** If there is a way for me to completely uninstall and reinstall Samba to the
original RedHat 9.0 install settings, without needing to do a full system
reinstall, that would be great because I could start with a clean slate.  I
forgot to backup the smbusers and smb.conf files before I started messing around
and now don't have the virgin copies.

Version-Release number of selected component (if applicable):
1.0.4

How reproducible:
Always

Steps to Reproduce:
1. Follow instructions on RH 9 Samba docs
2.
3.
    

Actual Results:  Same as described.

Expected Results:  This may be how it is supposed to work; I don't really know.
 In my opinion, the smbpasswd file should be created when Encrypted Passwords is
set to Yes under the security settings, and the users password should actually
be set when you add them as a Samba user in the interface.  You should not have
to manually create the password file and set the password from the command line,
and the users list should not be filled with the smbpasswd file but the smbusers
file instead.

The documentation for RH 9 Samba
http://www.redhat.com/docs/manuals/linux/RHL-9-Manual/custom-guide/ch-samba.html
, while nicely written, seems misleading or at leat organized incorrectly to
allow for a smooth installation.  The section on creating the Encrypted Password
file is thrown in at the end and should be included where the Encrypted Password
flag is discussed.  It is currently linked in the Encrypted Password Section,
but it should be mentioned that if one is using the flag, they need to skip
forward then come back before continuing.

Additional info:
Comment 1 Brent Fox 2003-09-02 20:04:21 EDT
I'm not really sure where the problem is.  You should not have to create the
smbpasswd by hand.  

To reset the system to the initial settings, you should try uninstalling samba,
samba-common and redhat-config-samba.  Then delete any remaining files in
/etc/samba/.  Then reinstall samba, samba-common, and redhat-config-samba.

I am not able to reproduce the behavior you are seeing.  Please reopen this bug
report if you can duplicate the behavior after reinstalling the packages.

Note You need to log in before you can comment on or make changes to this bug.