Bug 905143 - udev rules in the wrong place
Summary: udev rules in the wrong place
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hplip
Version: 6.4
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Tim Waugh
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
: 893003 962606 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-28 16:56 UTC by Tim Waugh
Modified: 2014-06-19 08:46 UTC (History)
6 users (show)

Fixed In Version: hplip-3.12.4-6.el6
Doc Type: Bug Fix
Doc Text:
Previously, the udev rules files were not in the correct location on the file system. As a consequence, permissions on the device node after connecting a device were insufficient. This update moves the udev rules files to the correct location, and udev rules now work correctly in the described situation.
Clone Of:
Environment:
Last Closed: 2014-06-19 08:46:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0767 normal SHIPPED_LIVE hplip bug fix update 2014-06-19 12:45:21 UTC

Description Tim Waugh 2013-01-28 16:56:02 UTC
Description of problem:
The hplip 3.12.4 re-base puts its udev rules in the wrong location.  Instead of /usr/lib/udev/rules.d it should be /lib/udev/rules.d.

Version-Release number of selected component (if applicable):
hplip-3.12.4-4.el6

Steps to Reproduce:
1.Connect a multi-function device.
2.Try scanning.
  
Actual results:
Insufficient permissions on device node.

Comment 2 Phil Knirsch 2013-01-30 14:58:26 UTC
Proposing as a blocker as without the very simple fix scanning with locally attached scanners would be completely broken and a regression from RHEL-6.3.

Thanks & regards, Phil

Comment 3 Phil Knirsch 2013-01-30 16:04:45 UTC
After discussion we agreed that local scanners aren't a critical use case so we're moving the fix to be addressed in RHEL-6.5.

Thanks & regards, Phil

Comment 8 Tim Waugh 2013-05-13 14:15:37 UTC
*** Bug 893003 has been marked as a duplicate of this bug. ***

Comment 9 Tim Waugh 2013-05-17 13:39:27 UTC
*** Bug 962606 has been marked as a duplicate of this bug. ***

Comment 12 Joost Ringoot 2013-10-30 21:00:11 UTC
xsane works for root. 

I tried  working around the issue by making symbolic links in /lib/udev/rules.d to all the files in: /usr/lib/udev/rules.d/*

like this:
ln -s /usr/lib/udev/rules.d/* /lib/udev/rules.d/

xsane still doesn't work for the user.

I removed the links and copied the files from /usr/lib/udev/rules.d to /lib/udev/rules.d 

xsane still doesn't work for the user.

If you have a workaround, please add it as a comment.

Thanks,

Comment 13 Joost Ringoot 2013-10-30 21:13:23 UTC
Correction on the previous comment: copying the files to the correct location helps,... only after reboot.
Udev rules are read only at boot.

Comment 19 errata-xmlrpc 2014-06-19 08:46:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0767.html


Note You need to log in before you can comment on or make changes to this bug.