Bug 90524 - post scriplet fails
Summary: post scriplet fails
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gtk2   
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-09 09:22 UTC by Sepp Rudel
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-10 22:35:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sepp Rudel 2003-05-09 09:22:36 UTC
Description of problem:
While I was updating from RHL7.3->RHL9 with apt (yea, I know, not supported by
RH, but read on...), gtk2 gave following error:

  59:gtk2                   ########################################### [  8%]
/usr/bin/gtk-query-immodules-2.0: error while loading shared libraries:
libXrandr.so.2: cannot open shared object file: No such file or directory
Cannot load loader /usr/lib/gtk-2.0/2.2.0/loaders/libpixbufloader-png.so

Probably caused by the fact that also RPM containing libXrandr.so.2 was about to
be updated after gtk2 during the same "rpm -Uvh" run. This caused gtk2 to be
misconfigured. This might well happen also with up2date/rpm -Fvh/yum/etc.

Version-Release number of selected component (if applicable):
All, I presume.

How reproducible:
Always.

Steps to Reproduce:
1.update gtk2 and XFree86 RPMs in the same run, XFree86 RPMs with new libXrandr.so
    
Actual results:
gtk2 install fails.

Expected results:
gtk2 install ok.

Additional info:
I also mention that during RHL7.3->RHL9 update, out of about 700 RPMs only pango
and gtk2 gave errors, so otherwise looking real good. pango report is #90523.

Comment 1 Owen Taylor 2003-06-10 22:35:51 UTC
After much discussion, we decided that this was either due to:
 
 - An old version of RPM used during the upgrade
 - A bug in apt-rpm

In the absence of dependency loops, and I don't think one is involved
here, there is no difference between Prereq: and Requires:, so 
XFree86-4.3 should have been upgraded before gtk2.

(Closing as NOTABUG since it is apparently not a bug in Red Hat's
configuration or tools we ship. It's clearly a bug *somewhere*)


Comment 2 Sepp Rudel 2003-06-11 08:36:57 UTC
Ok. Some comments, though:

- I doubt the "apt-rpm bug" because it just calls "rpm -Uvh" during upgrade process.
- rpm version I used was the one from RHL7.3.
- during upgrade by apt happens following:
  * rpm -e for a bunch of RPMs which are replaced/obsoleted/etc by RHL9 RPMs
  * rpm -Uvh for all needed RHL9 RPMs
  * both rpm -e and rpm -Uvh are done just once


Note You need to log in before you can comment on or make changes to this bug.