Bug 90525 - console.perms does not affect directory ownership
Summary: console.perms does not affect directory ownership
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: pam   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-09 09:59 UTC by Tim Waugh
Modified: 2015-01-08 00:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 08:59:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Waugh 2003-05-09 09:59:20 UTC
Description of problem:
When trying to access my compact flash card via /mnt/camera, I have to chown it
to my user account before I can mount it.  But console.perms has:

[...]
<camera>=/mnt/camera* /dev/usb/dc2xx* /dev/usb/mdc800*
[...]
<console>  0600 <camera>     0600 root

The reason this isn't a problem for floppy drives is that the device node is
also listed in console.perms; for USB mass storage that isn't known.

Version-Release number of selected component (if applicable):
pam-0.75-48

How reproducible:
100%

Steps to Reproduce:
1. Log on at the console.
2. Compare ownership of /dev/fd0 and /mnt/floppy:

ls -ld /dev/fd0 /mnt/floppy
    
Actual results:
/mnt/floppy is owned by root only.

Expected results:
Owners should match.

Additional info:

Comment 1 Tomas Mraz 2004-09-22 08:11:32 UTC
Actually you need to have ownership of the device, not a mount point,
to be able to mount it.

pam_console looks for mount point in /etc/fstab and changes the
ownership of the appropriate device.
So for mounting the camera device to work, you need to have correct
entry in fstab.

This way it works at least in FC2 but IMHO it was like this much earlier.



Note You need to log in before you can comment on or make changes to this bug.