Bug 90526 - Config uses ATI Radeon 9000 instead of ATI Radeon 9000 Pro
Config uses ATI Radeon 9000 instead of ATI Radeon 9000 Pro
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
: EasyFix, Triaged
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2003-05-09 06:44 EDT by Mike Chambers
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-15 10:17:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86 Log File (44.20 KB, text/plain)
2003-05-09 06:47 EDT, Mike Chambers
no flags Details
XFree86 Config file (3.20 KB, text/plain)
2003-05-09 06:48 EDT, Mike Chambers
no flags Details
Output of lspci -vvn (6.42 KB, text/plain)
2003-05-09 06:50 EDT, Mike Chambers
no flags Details

  None (edit)
Description Mike Chambers 2003-05-09 06:44:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401

Description of problem:
When XFree86 is configured, the config file/server uses ATI Radeon 9000 instead
of ATI Radeon 9000 Pro.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-8

How reproducible:
Always

Steps to Reproduce:
1.run redhat-config-xfree86
2.or install and let firstboot detect and configure video
3.
    

Actual Results:  Section "Device"
        Identifier  "Videocard0"
        Driver      "radeon"
        VendorName  "Videocard vendor"
        BoardName   "ATI Radeon 9000"
EndSection

Expected Results:  Section "Device"
        Identifier  "Videocard0"
        Driver      "radeon"
        VendorName  "Videocard vendor"
        BoardName   "ATI Radeon 9000 Pro"
EndSection

Additional info:

This was filed against rawhide as that is what I am currently running and to
make sure everything was on the same page.  I believe another person that has
this problem is using the official packages from Red Hat Linux 9.
Comment 1 Mike Chambers 2003-05-09 06:47:47 EDT
Created attachment 91579 [details]
XFree86 Log File
Comment 2 Mike Chambers 2003-05-09 06:48:32 EDT
Created attachment 91580 [details]
XFree86 Config file
Comment 3 Mike Chambers 2003-05-09 06:50:57 EDT
Created attachment 91581 [details]
Output of lspci -vvn
Comment 4 Mike A. Harris 2004-09-29 18:39:34 EDT
This is fixed in Fedora Core 1 and later.

Closing as "CURRENTRELEASE"
Comment 5 Mike A. Harris 2004-09-29 18:48:01 EDT
Oops, I misread this bug and got things backwards.  This PCI ID
still points to 9000 instead of 9000Pro, although this is just
a minor cosmetic issue and not a bug per se.

Marking as FC3Target to fix for FC3.
Comment 6 Mike A. Harris 2004-09-29 18:54:35 EDT
http://pciids.sourceforge.net/iii/?i=10024966

Some cards of this device ID are "Pro" variants, some are not,
depending on the manufacturer.  For a given PCI ID, I consider
official Built by ATI hardware to be canonical.

Mike's card is subvendor/subdevice 1002:0002 which indicates this
is a real Built by ATI board.  So, this entry should be changed
to "9000 Pro" probably, and any non-pro's can be overridden with
subdevice specifications in pcitable if anyone else files bug
reports in the future for misnamed cards.


Note You need to log in before you can comment on or make changes to this bug.