Bug 905398 - ovirt-engine-backend: backend version information does not include z/micro versions.
Summary: ovirt-engine-backend: backend version information does not include z/micro ve...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.2.0
Assignee: Douglas Schilling Landgraf
QA Contact: Elena
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-29 10:46 UTC by Oded Ramraz
Modified: 2016-02-10 19:03 UTC (History)
14 users (show)

Fixed In Version: sf15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-30 09:06:06 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 14079 None None None Never

Description Oded Ramraz 2013-01-29 10:46:16 UTC
Description of problem:

When pressing the about button in UI I get this version for engine : " oVirt Engine Version: 3.2.0-5.el6ev "
When looking for the same information in Rest API I don't see the right revision ( 0 compared to 5 ) :
<product_info><name>oVirt Engine</name><vendor>ovirt.org</vendor><version major="3" minor="2" build="0" revision="0"/></product_info>

Seems like about page retrieves the information from the rpm and rest api retrieve the ( inaccurate ) information from BE 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Itamar Heim 2013-01-30 09:06:06 UTC

*** This bug has been marked as a duplicate of bug 904230 ***

Comment 2 Oded Ramraz 2013-01-30 09:24:18 UTC
Not sure it is the same issue as in bug 904230 , here I'm talking about the version that Rest / CLI presents and not the one in about page ( which is taken from rpm )

Comment 3 Itamar Heim 2013-01-30 09:52:48 UTC
I'm opening since i agree with you it is not the same.
however, before fixing this, a decision if we are not dropping the z/micro version (major/minor/micro) should be reached.

Comment 7 Douglas Schilling Landgraf 2013-03-26 02:25:09 UTC
Reproduce on SF11. 

REST is getting data from VdcVersion:

# select option_value from vdc_options where option_name='VdcVersion';
 option_value 
--------------
 3.2.0.0

About window is getting from ProductRPMVersion:

# select option_value from vdc_options where option_name='ProductRPMVersion';
                     option_value                     
------------------------------------------------------
 3.2.0-10.0.3.20130325gitb19951b.douglas.master.el6ev
(1 row)


For the record, python source to display version
====================================================
import urllib2
import base64
import sys
from xml.etree import ElementTree

# Example
ADDR     = "192.168.122.139"
API_PORT = "443"
USER     = "admin@internal"
PASSWD   = "MysuperPassword"

# Setting URL
URL      = "https://" + ADDR + ":" + API_PORT + "/api"

request = urllib2.Request(URL)
print "Connecting to: " + URL

base64string = base64.encodestring('%s:%s' % (USER, PASSWD)).strip()
request.add_header("Authorization", "Basic %s" % base64string)

try:
        xmldata = urllib2.urlopen(request).read()
except urllib2.URLError, e:
        print "Error: cannot connect to REST API: %s" % (e)
        print "Try to login using the same user/pass by the Admin Portal and check the error!"
        sys.exit(2)

tree = ElementTree.XML(xmldata)
list = tree.findall("product_info")

for item in list:
        print item.find("name").text
        print item.find("version").attrib

Comment 8 Douglas Schilling Landgraf 2013-03-29 06:43:59 UTC
# python version_api.py 
Connecting to: https://192.168.122.135:443/api
Red Hat Enterprise Virtualization Manager
{
'major': '3', 
'full_version': '3.2.0-10.0.63.20130329gitd3892f0.douglas.master.el6ev', 
'build': '0', 
'minor': '2', 
'revision': '0'
}

Comment 9 Douglas Schilling Landgraf 2013-04-10 20:34:11 UTC
From http://rhevm/api
=====================

<snip>

<product_info>
<name>oVirt Engine</name>
<vendor>ovirt.org</vendor>
<version revision="0" build="0" minor="3" major="3"/>
<full_version>3.3.0-0.2.master.20130410180404.fc18</full_version>
</product_info>

</snip>

Comment 12 Elena 2013-05-07 12:26:56 UTC
Verified in sf15:
<full_version>3.2.0-10.21.master.el6ev</full_version>

Comment 13 Itamar Heim 2013-06-11 09:46:18 UTC
3.2 has been released

Comment 14 Itamar Heim 2013-06-11 09:46:24 UTC
3.2 has been released

Comment 15 Itamar Heim 2013-06-11 09:56:22 UTC
3.2 has been released


Note You need to log in before you can comment on or make changes to this bug.