This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 905417 - [abrt] libreoffice-core-3.6.3.2-8.fc18: GtkSalGraphics::NWPaintGTKProgress -> gtk_paint_box -> _cairo_xlib_shm_surface_create.isra.13 -> _XIOError
[abrt] libreoffice-core-3.6.3.2-8.fc18: GtkSalGraphics::NWPaintGTKProgress ->...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Eike Rathke
Fedora Extras Quality Assurance
abrt_hash:90c2f8cc921ca4c1d59e44bf8e4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-29 07:07 EST by jmperezcorreas
Modified: 2013-04-16 06:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-16 06:32:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (36.43 KB, text/plain)
2013-01-29 07:07 EST, jmperezcorreas
no flags Details
File: build_ids (7.57 KB, text/plain)
2013-01-29 07:07 EST, jmperezcorreas
no flags Details
File: cgroup (127 bytes, text/plain)
2013-01-29 07:07 EST, jmperezcorreas
no flags Details
File: dso_list (18.47 KB, text/plain)
2013-01-29 07:08 EST, jmperezcorreas
no flags Details
File: environ (1.51 KB, text/plain)
2013-01-29 07:08 EST, jmperezcorreas
no flags Details
File: limits (1.29 KB, text/plain)
2013-01-29 07:08 EST, jmperezcorreas
no flags Details
File: maps (58.37 KB, text/plain)
2013-01-29 07:08 EST, jmperezcorreas
no flags Details
File: open_fds (246 bytes, text/plain)
2013-01-29 07:08 EST, jmperezcorreas
no flags Details
File: proc_pid_status (786 bytes, text/plain)
2013-01-29 07:08 EST, jmperezcorreas
no flags Details
File: RegistreSD.xlsx (4.36 MB, application/octet-stream)
2013-01-29 07:12 EST, jmperezcorreas
no flags Details

  None (edit)
Description jmperezcorreas 2013-01-29 07:07:32 EST
Description of problem:
Opening a big Excel document.

Version-Release number of selected component:
libreoffice-core-3.6.3.2-8.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/lib/libreoffice/program/soffice.bin --calc /home2/jmpc/Documents/GtdV02.ods /home2/jmpc/Documents/PlanifV02.ods /home2/jmpc/Documents/TornsSDv02.xlsx --splash-pipe=6
core_backtrace: 
crash_function: operator delete
executable:     /usr/lib/libreoffice/program/soffice.bin
kernel:         3.7.4-204.fc18.i686
remote_result:  NOTFOUND
uid:            1000
var_log_messages: Jan 29 09:59:17 localhost abrt[6602]: Saved core dump of pid 6465 (/usr/lib/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2013-01-29-09:59:13-6465 (164769792 bytes)

Truncated backtrace:
Thread no. 1 (7 frames)
 #6 operator delete at ../../../../libstdc++-v3/libsupc++/del_op.cc:48
 #7 typelib_typedescription_release at /usr/lib/libreoffice/program/../ure-link/lib/libuno_cppu.so.3
 #8 typelib_typedescriptionreference_release at /usr/lib/libreoffice/program/../ure-link/lib/libuno_cppu.so.3
 #9 uno_any_destruct at /usr/lib/libreoffice/program/../ure-link/lib/libuno_cppu.so.3
 #10 framework::WakeUpThread::run() at /usr/lib/libreoffice/program/../program/libfwklo.so
 #11 threadFunc at /usr/lib/libreoffice/program/../program/libfwklo.so
 #12 osl_thread_start_Impl at /usr/lib/libreoffice/program/../ure-link/lib/libuno_sal.so.3
Comment 1 jmperezcorreas 2013-01-29 07:07:41 EST
Created attachment 689759 [details]
File: backtrace
Comment 2 jmperezcorreas 2013-01-29 07:07:52 EST
Created attachment 689760 [details]
File: build_ids
Comment 3 jmperezcorreas 2013-01-29 07:07:56 EST
Created attachment 689761 [details]
File: cgroup
Comment 4 jmperezcorreas 2013-01-29 07:08:00 EST
Created attachment 689762 [details]
File: dso_list
Comment 5 jmperezcorreas 2013-01-29 07:08:03 EST
Created attachment 689763 [details]
File: environ
Comment 6 jmperezcorreas 2013-01-29 07:08:05 EST
Created attachment 689764 [details]
File: limits
Comment 7 jmperezcorreas 2013-01-29 07:08:07 EST
Created attachment 689765 [details]
File: maps
Comment 8 jmperezcorreas 2013-01-29 07:08:11 EST
Created attachment 689766 [details]
File: open_fds
Comment 9 jmperezcorreas 2013-01-29 07:08:13 EST
Created attachment 689767 [details]
File: proc_pid_status
Comment 10 jmperezcorreas 2013-01-29 07:12:29 EST
Created attachment 689768 [details]
File: RegistreSD.xlsx
Comment 11 Stephan Bergmann 2013-01-29 08:59:02 EST
The SIGABRT in thread 1 is a consequence of GtkSalGraphics::NWPaintGTKProgress -> gtk_paint_box -> _cairo_xlib_shm_surface_create.isra.13 -> _XIOError -> __run_exit_handlers in thread 3.

Can you reproduce this crash?  If yes, can you attach the document that causes it?
Comment 12 Caolan McNamara 2013-02-28 10:38:50 EST
The attachment in comment #10 is presumably the document that's believed to trigger the crash :-)
Comment 13 Caolan McNamara 2013-02-28 11:09:39 EST
Doesn't crash X for me, might be coincidence that X "went away" or some OOM. It is a v. long load time.

caolanm->erack: give this .xlsx a once over to see if it blows up anything for you.
caolanm->jmperezcorreas: does this always crash for you, or was it a one time thing ?
Comment 14 Caolan McNamara 2013-04-16 06:32:24 EDT
Looks like the server went away while LibreOffice was running, i.e. can't fix

Note You need to log in before you can comment on or make changes to this bug.