Bug 905424 - Tabs, buttons and other SmartGWT components are broken in Firefox 18
Tabs, buttons and other SmartGWT components are broken in Firefox 18
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.5
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: Jirka Kremser
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-29 07:21 EST by Jirka Kremser
Modified: 2013-02-19 10:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-19 10:28:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Broken UI (370.27 KB, image/png)
2013-01-29 07:22 EST, Jirka Kremser
no flags Details

  None (edit)
Description Jirka Kremser 2013-01-29 07:21:13 EST
Description of problem:
There is a problem when using Firefox 18.0. The UI is broken, as well as the SmartGWT official showcase. If user press refreshes the page (without clearing the cache - F5), the problem is solved.

It is bug in SmartGWT as described here (http://forums.smartclient.com/showthread.php?t=24956). In the forum there are some workarounds for particular components.

How reproducible:
always

Steps to Reproduce:
1. install FF18
2. open rhq web ui
3. ctrl+f5 (clearing the cache)

Version-Release number of selected component (if applicable):
4.6.0-SNAPSHOT

SmartGWT version: 3.0 (the problem is also in the 3.1 version)
Comment 1 Jirka Kremser 2013-01-29 07:22:47 EST
Created attachment 689770 [details]
Broken UI
Comment 2 Jirka Kremser 2013-02-04 07:06:43 EST
some important comments from the smart client forum:

"Mozilla has acknowledged it as a bug and a proposed patch has been attached to the bug."  "..they are currently saying that the fix is likely to just come out with Firefox 19 or 20 rather than Firefox 18.0.1"

"Please try the next nightly build, dated Jan 18
We believe these issues (including the breakage of closeable tabs) are now resolved"

I confirm that if I use nightly 3.1-SNAPSHOT for building the RHQ, the issues are gone. Unfortunately, they don't have nightly builds in their Maven repo. I downloaded it from http://www.smartclient.com/builds/SmartGWT/3.1p/LGPL
Comment 5 Jirka Kremser 2013-02-19 10:28:08 EST
It is solved in FF19 (nightly build from 2013/02/15) and in FF17ESR
Comment 6 Mike Thompson 2013-02-19 10:39:06 EST
This is a closed issue so it doesn't probably matter but when I applied the patch a few weeks ago I noticed other issues with remoting crop up. I say this because it makes me nervous for future patches and what it might do to our app. Although the patch could be working by now.

Note You need to log in before you can comment on or make changes to this bug.