Bug 905438 - yum & yum-plugin-downloadonly: conflicting commandline option --downloadonly
Summary: yum & yum-plugin-downloadonly: conflicting commandline option --downloadonly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 18
Hardware: i686
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3116587fbae1e274ed868657447...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-29 12:58 UTC by junior
Modified: 2013-04-05 00:01 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-05 00:01:35 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.84 KB, text/plain)
2013-01-29 12:58 UTC, junior
no flags Details
File: core_backtrace (1.12 KB, text/plain)
2013-01-29 12:58 UTC, junior
no flags Details
File: dso_list (75 bytes, text/plain)
2013-01-29 12:58 UTC, junior
no flags Details
File: environ (2.53 KB, text/plain)
2013-01-29 12:58 UTC, junior
no flags Details

Description junior 2013-01-29 12:58:03 UTC
Description of problem:
O erro aconteceu apos a atualizacao da ferramenta 'yum'.
No shell do fedora foi digitado o comando 'yum install -y yum-*' e apos o fim da instalacao foi digitado o comando 'yum update', assim gerando o erro.

Version-Release number of selected component:
yum-3.4.3-48.fc18

Additional info:
cmdline:        /usr/bin/python /usr/bin/yum update
executable:     /usr/bin/yum
kernel:         3.6.10-4.fc18.i686
uid:            1000

Truncated backtrace:
optparse.py:995:_check_conflict:OptionConflictError: option --downloadonly: conflicting option string(s): --downloadonly

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 319, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 115, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 254, in getOptionsConfig
    self.conf
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1018, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 374, in _getConfig
    startupconf.pluginconfpath,disabled_plugins,enabled_plugins)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 621, in doPluginSetup
    plugin_types, confpath, disabled_plugins, enabled_plugins)
  File "/usr/lib/python2.7/site-packages/yum/plugins.py", line 165, in __init__
    self.run('config')
  File "/usr/lib/python2.7/site-packages/yum/plugins.py", line 187, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/downloadonly.py", line 30, in config_hook
    default=False, help="don't update, just download")
  File "/usr/lib/python2.7/optparse.py", line 1020, in add_option
    self._check_conflict(option)
  File "/usr/lib/python2.7/optparse.py", line 995, in _check_conflict
    option)
OptionConflictError: option --downloadonly: conflicting option string(s): --downloadonly

Local variables in innermost frame:
opt: '--downloadonly'
co: ('--downloadonly', <Option at 0x8c8190c: --downloadonly>)
option: <Option at 0x8f16f8c: --downloadonly>
conflict_opts: [('--downloadonly', <Option at 0x8c8190c: --downloadonly>)]
handler: 'error'
self: <optparse.OptionGroup instance at 0x8c7fd6c>

Comment 1 junior 2013-01-29 12:58:07 UTC
Created attachment 689812 [details]
File: backtrace

Comment 2 junior 2013-01-29 12:58:09 UTC
Created attachment 689813 [details]
File: core_backtrace

Comment 3 junior 2013-01-29 12:58:11 UTC
Created attachment 689814 [details]
File: dso_list

Comment 4 junior 2013-01-29 12:58:13 UTC
Created attachment 689815 [details]
File: environ

Comment 5 Zdeněk Pavlas 2013-01-29 16:08:55 UTC
You probably have yum-plugin-downloadonly installed and enabled.  Uninstall it or disable in /etc/yum/pluginconf.d/downloadonly.conf.  Now I've noticed that Yum obsoletes this plugin, maybe we should conflict instead.

Comment 6 Andrew McNabb 2013-02-01 17:39:11 UTC
I ran into this error, too. It's a critical problem because it means that _all_ yum commands now fail, and security updates are impossible until the problem is fixed.

Comment 7 Zdeněk Pavlas 2013-02-04 09:34:57 UTC
Did setting "enabled=0" in /etc/yum/pluginconf.d/fastestmirror.conf fix your issue?

Comment 8 alain.thiaville 2013-02-04 13:05:24 UTC
after  installation  yum-plugin-downloadonly

Package: yum-3.4.3-48.fc18
Architecture: x86_64
OS Release: Fedora release 18 (Spherical Cow)

Comment 9 Andrew McNabb 2013-02-04 16:31:09 UTC
(In reply to comment #7)
> Did setting "enabled=0" in /etc/yum/pluginconf.d/fastestmirror.conf fix your
> issue?

I did `rpm -e yum-plugin-downloadonly` to workaround the problem, but this seems like a problem that will make it so inexperienced users will just stop getting any security updates.

Comment 10 alain.thiaville 2013-02-05 08:51:46 UTC
in reply to comment #9 :

I did exactly the same workaround (i.e rpm -e yum-plugin-downloadonly). After
reading Comment 9. I reinstalled this faulty plugin (just for a while) and verified that "enabled=0" did the the trick too.
               --------------------------------
 The plugin is buggy but the workaround "enabled=0" is not a good a solution,
                             -----------------------------------------------
until the bug is corrected. (because yum update, yum install yum-plugin\* ...).
 To "download only" i use "yumdownloader" from "rpm-utils"

Comment 11 Fedora Update System 2013-02-06 10:48:22 UTC
yum-3.4.3-49.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/yum-3.4.3-49.fc18

Comment 12 Fedora Update System 2013-02-08 02:27:37 UTC
Package yum-3.4.3-49.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-3.4.3-49.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2076/yum-3.4.3-49.fc18
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2013-02-13 04:39:11 UTC
yum-3.4.3-49.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 ramindeh 2013-02-17 09:13:37 UTC
I have yum-3.4.3-49.fc18.

It was still necessary to disable the "downloadonly" plugin as per comment #5 above. After that, it worked.

Comment 15 Sergio Basto 2013-02-18 01:54:24 UTC
Hi.
yum install yum-plugin-downloadonly

Processing Conflict: yum-3.4.3-49.fc18.noarch conflicts yum-plugin-downloadonly <= 1.1.31-7.fc18

IMHO. is not right , should done yum-3.4.3-49 provides yum-plugin-downloadonly 

you should add to .spec
Provides:   yum-plugin-downloadonly = 1.1.31-7 

to delete yum-plugin-downloadonly on update of yum

Comment 16 Kevin Kofler 2013-02-19 06:35:55 UTC
Conflicts doesn't make sense here! The Obsoletes that was there before was already correct, it just needed to be bumped to Obsolete the current yum-plugins.

Comment 17 Kevin Kofler 2013-02-19 06:37:23 UTC
PS: The Conflicts is going to make it particularly hard to upgrade from F17 to F18 using the:
yum --releasever=18 --downloadonly distro-sync
telinit 3
yum --releasever=18 -C distro-sync
method, so please fix/revert this!

Comment 18 Fedora Update System 2013-02-19 08:55:21 UTC
yum-3.4.3-50.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/yum-3.4.3-50.fc18

Comment 19 Sergio Basto 2013-02-19 16:51:13 UTC
(In reply to comment #16)
> Conflicts doesn't make sense here! The Obsoletes that was there before was
> already correct, it just needed to be bumped to Obsolete the current
> yum-plugins.

Right : 
Obsoletes: yum-plugin-downloadonly < 1.1.31-7 

but add Provides, is also cool to: 
yum install yum-plugin-downloadonly 
will say "already installed" so please add:  

Provides:  yum-plugin-downloadonly = 1.1.31-7 


Also is documented in :
https://fedoraproject.org/wiki/Packaging:Guidelines#Renaming.2FReplacing_Existing_Packages

Comment 20 Fedora Update System 2013-02-20 03:55:01 UTC
Package yum-3.4.3-50.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-3.4.3-50.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2711/yum-3.4.3-50.fc18
then log in and leave karma (feedback).

Comment 21 Andrew Travneff 2013-02-28 17:23:43 UTC
(In reply to comment #17)
Just caught that. Solved with manual update of yum to f18 version before all another. Seems like all went fine, but this isn't the best case of course.

Comment 22 Fedora Update System 2013-03-25 14:50:03 UTC
yum-3.4.3-53.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/yum-3.4.3-53.fc18

Comment 23 Fedora Update System 2013-04-05 00:01:38 UTC
yum-3.4.3-53.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.