Bug 905499 - 3.1.3 - engine: after move of disk with snapshot in preview cannot run the vm
3.1.3 - engine: after move of disk with snapshot in preview cannot run the vm
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.2
x86_64 Linux
high Severity high
: ---
: 3.1.3
Assigned To: Nobody's working on this, feel free to take it
vvyazmin@redhat.com
storage
: ZStream
Depends On: 865021
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-29 09:15 EST by Chris Pelland
Modified: 2016-02-10 12:02 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, it was possible to move a virtual machine with a snapshot in preview mode, which caused a vdsm error. The moveImage command in vdsm cannot move disks of virtual machines that are in preview mode. An additional validation has been added to MoveDisksCommand to prevent such action.
Story Points: ---
Clone Of: 865021
Environment:
Last Closed: 2013-03-12 10:28:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11340 None None None Never

  None (edit)
Comment 1 Federico Simoncelli 2013-01-29 09:37:45 EST
Author: Federico Simoncelli <fsimonce@redhat.com>
Date:   Wed Jan 23 12:40:24 2013 -0500

    core: block MoveDisks on snapshot preview
    
    The moveImage command in VDSM (at the moment of this writing) cannot
    move disks of VMs that are in preview mode. An additional validation
    has been added to MoveDisksCommand to prevent such action for the time
    being.

http://gerrit.ovirt.org/#/c/11340/
Comment 3 vvyazmin@redhat.com 2013-02-10 11:20:56 EST
No issues are found

Verified on RHEVM 3.1 - SI27 environment:

RHEVM: rhevm-3.1.0-46.el6ev.noarch
VDSM: vdsm-4.10.2-7.0.el6ev.x86_64
LIBVIRT: libvirt-0.10.2-18.el6.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.348.el6.x86_64
SANLOCK: sanlock-2.6-2.el6.x86_64
Comment 5 errata-xmlrpc 2013-03-12 10:28:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0557.html

Note You need to log in before you can comment on or make changes to this bug.