Bug 905594 - Unable to install ipa-server-trust-ad pkg on 32-bit platform
Summary: Unable to install ipa-server-trust-ad pkg on 32-bit platform
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Rob Crittenden
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On:
Blocks: 907526
TreeView+ depends on / blocked
 
Reported: 2013-01-29 17:53 UTC by Namita Soman
Modified: 2013-02-21 09:32 UTC (History)
3 users (show)

Fixed In Version: ipa-3.0.0-25.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 09:32:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
error when installing ipa-server-trust-ad (4.13 KB, text/plain)
2013-01-29 17:53 UTC, Namita Soman
no flags Details
yum install with debug on (87.01 KB, text/plain)
2013-01-29 17:54 UTC, Namita Soman
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2013:0528 normal SHIPPED_LIVE Low: ipa security, bug fix and enhancement update 2013-02-21 08:22:21 UTC

Description Namita Soman 2013-01-29 17:53:09 UTC
Created attachment 689973 [details]
error when installing ipa-server-trust-ad

Description of problem:
unable to install ipa-server-trust-ad pkg, fails dependencies

output of yum -d 10 install ipa-server-trust-ad includes: 
--> Processing Dependency: libwbclient.so.0 for package: ipa-server-trust-ad-3.0.0-24.el6.i686
<ab> Searching pkgSack for dep: libwbclient.so.0
<ab> TSINFO: Marking samba-winbind-clients-3.6.9-151.el6.i686 as install for ipa-server-trust-ad-3.0.0-24.el6.i686

Version-Release number of selected component (if applicable):
ipa-server-3.0.0-24.el6.i686
samba4-libs-4.0.0-55.el6.rc4.i686

How reproducible:
always on 32bit

Steps to Reproduce:
1. Started with no samaba pkgs installed
2. install ipa-server pkg -> yum install ipa-server
3. install ipa-server-trust-ad pkg -> yum install ipa-server-trust-ad
  
Actual results:
unable to install ipa-server-trust-ad pkg, fails dependencies

Expected results:
be able to install ipa-server-trust-ad pkg (like it does on 64bit platform)

Additional info:
ab took a look at ipa.spec and said:
diff --git a/ipa.spec b/ipa.spec
index 5637c69..06577cf 100644
--- a/ipa.spec
+++ b/ipa.spec
 -249,7 +249,7 @@ Requires(post): python
 Requires(postun): %{_sbindir}/update-alternatives
 Requires(preun): %{_sbindir}/update-alternatives
 %{?filter_setup:
-%filter_from_requires /libwbclient.so.0()/d
+%filter_from_requires /libwbclient.so.0()/d; /libwbclient.so.0$/d;
 %filter_setup
 }

Comment 1 Namita Soman 2013-01-29 17:54:33 UTC
Created attachment 689975 [details]
yum install with debug on

Comment 2 Rob Crittenden 2013-01-29 18:20:49 UTC
Caused by changes in latest samba4 build.

Comment 3 Rob Crittenden 2013-01-30 15:30:46 UTC
Applied Alexander's patch to spec file.

Comment 5 Michael Gregg 2013-01-31 02:17:28 UTC
That change still seems to cause problems. 


When I run "yum install ipa-server-trust-ad", I get:
Error: samba4-winbind conflicts with samba-winbind-3.6.9-151.el6.i686
Error: samba4-common conflicts with samba-common-3.6.9-151.el6.i686
Error: samba4-winbind-clients conflicts with samba-winbind-clients-3.6.9-151.el6.i686

It appears to be attempting to resolve the library libwbclient.so.0

If I download the rpm manually, then attempt a install, I get:

[root@zippyvm11 dev-shm-backup]# rpm -i ./ipa-server-trust-ad-3.0.0-23.el6.i686.rpm 
warning: ./ipa-server-trust-ad-3.0.0-23.el6.i686.rpm: Header V3 RSA/SHA256 Signature, key ID f21541eb: NOKEY
error: Failed dependencies:
	libwbclient.so.0 is needed by ipa-server-trust-ad-3.0.0-23.el6.i686

That library is in fact on the system:

[root@zippyvm11 dev-shm-backup]# locate libwbclient.so.0
/usr/lib/samba/libwbclient.so.0

Perhaps drop the requirement for libwbclient.so.0 and replace it with a requirement for samba4-libs?

Comment 6 Rob Crittenden 2013-01-31 03:02:34 UTC
You need ipa-server-trust-ad-3.0.0-25.el6 to address this issue. You tested with -23.

Comment 7 Michael Gregg 2013-01-31 03:56:12 UTC
Oh yes. 

After repos were updated, the package installs properly

[root@zippyvm11 dev-shm-backup]# yum install ipa-server-trust-ad
---> Package ipa-server-trust-ad.i686 0:3.0.0-25.el6 will be installed
--> Processing Dependency: ipa-server = 3.0.0-25.el6 for package: ipa-server-trust-ad-3.0.0-25.el6.i686
--> Running transaction check
---> Package ipa-server.i686 0:3.0.0-23.el6 will be updated
--> Processing Dependency: ipa-server = 3.0.0-23.el6 for package: ipa-server-selinux-3.0.0-23.el6.i686
--> Processing Dependency: ipa-server = 3.0.0-23.el6 for package: ipa-server-selinux-3.0.0-23.el6.i686
---> Package ipa-server.i686 0:3.0.0-25.el6 will be an update
--> Processing Dependency: ipa-python = 3.0.0-25.el6 for package: ipa-server-3.0.0-25.el6.i686
--> Processing Dependency: ipa-client = 3.0.0-25.el6 for package: ipa-server-3.0.0-25.el6.i686
--> Processing Dependency: ipa-admintools = 3.0.0-25.el6 for package: ipa-server-3.0.0-25.el6.i686
--> Running transaction check
---> Package ipa-admintools.i686 0:3.0.0-23.el6 will be updated
---> Package ipa-admintools.i686 0:3.0.0-25.el6 will be an update
---> Package ipa-client.i686 0:3.0.0-23.el6 will be updated
---> Package ipa-client.i686 0:3.0.0-25.el6 will be an update
---> Package ipa-python.i686 0:3.0.0-23.el6 will be updated
---> Package ipa-python.i686 0:3.0.0-25.el6 will be an update
---> Package ipa-server-selinux.i686 0:3.0.0-23.el6 will be updated
---> Package ipa-server-selinux.i686 0:3.0.0-25.el6 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

Installed:
  ipa-server-trust-ad.i686 0:3.0.0-25.el6                                                                                                                          

Dependency Updated:
  ipa-admintools.i686 0:3.0.0-25.el6            ipa-client.i686 0:3.0.0-25.el6        ipa-python.i686 0:3.0.0-25.el6        ipa-server.i686 0:3.0.0-25.el6       
  ipa-server-selinux.i686 0:3.0.0-25.el6       

Complete!

Comment 9 errata-xmlrpc 2013-02-21 09:32:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHSA-2013-0528.html


Note You need to log in before you can comment on or make changes to this bug.