Bug 90565 - cdrecord uses sg0 when it should use sg2
cdrecord uses sg0 when it should use sg2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: cdrecord (Show other bugs)
9
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
: 88512 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-09 13:45 EDT by Patrick C. F. Ernzer
Modified: 2007-04-18 12:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-16 04:46:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/etc/cdrecord.conf (1.06 KB, text/plain)
2003-05-09 13:47 EDT, Patrick C. F. Ernzer
no flags Details

  None (edit)
Description Patrick C. F. Ernzer 2003-05-09 13:45:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
maybe I just missed something obvious, but my CDwriter is at sg2 and cdrecord
will try sg0.

/etc/cdrecord.conf points to '1,6,0' and as such I think not specifying a device
should be OK.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. configure /etc/cdrecord.conf
2. call mkisofs -quiet -J -R -V 'blarp' file | cdrecord  -v -eject -
3. or call mkisofs -quiet -J -R -V 'blarp' file | cdrecord dev=1,6,0 -v -eject -
    

Actual Results:  Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 J?rg
Schilling
TOC Type: 1 = CD-ROM
cdrecord: Operation not permitted. WARNING: Cannot do mlockall(2).
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
cdrecord: Permission denied. WARNING: Cannot set priority using setpriority().
cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: '1,6,0'
scsibus: 1 target: 6 lun: 0
cdrecord: Permission denied. Cannot open '/dev/sg0'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.


Expected Results:  access to sg2

Additional info:

mkisofs -quiet -J -R -V 'blarp' file | cdrecord dev=/dev/sg2 -v -eject -
works
Comment 1 Patrick C. F. Ernzer 2003-05-09 13:46:35 EDT
$ ll /dev/cdwriter
lrwxrwxrwx    1 root     root            8 May  9 19:00 /dev/cdwriter -> /dev/sg2
$ ll /dev/sg0
crw-rw----    1 root     disk      21,   0 Jan 30 11:24 /dev/sg0
$ ll /dev/sg2
crw-rw-rw-    1 pcfe     disk      21,   2 Jan 30 11:24 /dev/sg2
Comment 2 Patrick C. F. Ernzer 2003-05-09 13:47:23 EDT
Created attachment 91594 [details]
/etc/cdrecord.conf
Comment 3 Patrick C. F. Ernzer 2003-05-09 13:48:39 EDT
doh! forgot version of component:
$ rpm -q cdrecord
cdrecord-2.0-6
Comment 4 Patrick C. F. Ernzer 2003-05-13 11:21:01 EDT
OK, the test package you made (2.0-7) fixes the problem (for nautilus-cd-burner
as well, as expected).

feel free to close
Comment 5 Alexander Larsson 2003-07-07 05:42:39 EDT
*** Bug 88512 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.