Bug 905657 - qemu with vmware driver at resolution 720x576 may unexpectedly exit on X error
qemu with vmware driver at resolution 720x576 may unexpectedly exit on X error
Status: CLOSED DUPLICATE of bug 836260
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-29 16:28 EST by Steve Tyler
Modified: 2013-04-01 20:39 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-01 20:39:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
qemu session with error messages (4.08 KB, text/plain)
2013-01-29 16:33 EST, Steve Tyler
no flags Details

  None (edit)
Description Steve Tyler 2013-01-29 16:28:33 EST
Description of problem:
With the vmware driver, setting the display resolution to 720x576 may cause qemu to unexpectedly exit on an X error:

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  140 (MIT-SHM)
  Minor opcode of failed request:  3 (X_ShmPutImage)
  Value in failed request:  0xff9b
  Serial number of failed request:  3695
  Current serial number in output stream:  3696

Version-Release number of selected component (if applicable):
qemu-kvm-1.0.1-3.fc17.x86_64
Fedora-18-x86_64-Live-Desktop.iso

How reproducible:
Always.

Steps to Reproduce:
1. Start the F18 Live CD with qemu on an F17 host:
$ qemu-kvm -m 2048 -cdrom ~/xfr/fedora/F18/F18-Final/Final/Fedora-18-x86_64-Live-Desktop.iso -vga vmware

2. Proceed to the desktop.
3. Start System Settings.
4. Click Displays.
5. Select resolution "720 x 576 (5:4)".
6. Click Apply.
7. Click Keep This Configuration.
8. Drag System Settings window to left to display close button.
9. Move pointer over close button.
  
Actual results:
qemu exits.

Expected results:
qemu does not exit.

Additional info:
Comment 1 Steve Tyler 2013-01-29 16:33:33 EST
Created attachment 690034 [details]
qemu session with error messages
Comment 2 Steve Tyler 2013-01-29 17:48:12 EST
Reproduced with an F18 host. Changing version to 18.

$ rpm -qa 'qemu*' | sort
qemu-common-1.2.2-4.fc18.x86_64
qemu-img-1.2.2-4.fc18.x86_64
qemu-kvm-1.2.2-4.fc18.x86_64
qemu-system-x86-1.2.2-4.fc18.x86_64
Comment 3 Cole Robinson 2013-04-01 20:39:04 EDT
Thanks for the reproducer Steve, it reproduced for me. A patch for another vmware issue also fixes this one, so duping to that bug.

*** This bug has been marked as a duplicate of bug 836260 ***

Note You need to log in before you can comment on or make changes to this bug.