Bug 905711 - Custom partitioning doesn't work
Custom partitioning doesn't work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-29 20:51 EST by Tom
Modified: 2013-01-30 18:15 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-30 10:07:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom 2013-01-29 20:51:10 EST
Description of problem: anaconda sucks. Custom partitioning is stuck at "Error checking storage configuration."


Version-Release number of selected component (if applicable): Fedora 18 XFCE 64bit


How reproducible: easily


Steps to Reproduce:
1. Boot from F18 to install it
2. Select custom partitioning
3. The new UI is clumsy and unintuitive, and will not execute my partitioning setup
  
Actual results: New software should be intuitive - anaconda is anything but.


Expected results:


1) Where is the drop-down list of mount points when changing an existing partition? Just because a user wants to do custom partitioning doesn't mean they know (or can remember) the correct choices.

2) Displaying choices after I type the / (for mount points) is odd. Just give me a frigging drop-down.

3) "New Fedora 18 installation" followed by "Unknown" is unintuitive. My "unknown" became sda1, which comes before any of the partitions used above it in the "New" section.

4) The need to expand Unknown so you can add partitions is unintuitive. 

5) The Available Space being separated from the partitions is unintuitive

6) The File System option is greyed out until I click the Reformat button. WFT?

7) The awful UI design/colors add to the confusion, because it isn't obvious that the thing next to "Reformat" is a checkbox.

8) When you add a new partition, the Encrypt and File System options should be chosen at the same time as the mount point. Separating them is just asking for things to be forgotten (oh crap, I meant to encrypt /home, but forgot.)

9) Filling up the entire screen with the UI on a 17" screen creates a ton of white space that adds to the confusion.

10) The last partition that I selected was /home, and I told it to use the exact amount of "available space" shown in the red box. So why does that red box still show 4.83 MB available? If the UI was decent, I could actually see the white space between partitions, although 4.83 MB of white space because of cylinder alignment seems excessive.

11) I am about to finish partitioning, which will write my changes to the disk, but I am afraid to do that because I'm not really sure what it is about to do. I have a 2nd drive that the installation is not supposed to touch, but because of the awful UI, I can't be sure of what it is about to do.

12) Oh, sh*t, I get an error after defining the above partitioning. Why does it wait until the "Installation Summary" to complain?

13) OK, so I go back and click on my installation drive. Now what? Continue? But I haven't fixed anything yet? Maybe I need the "Full disk summary and options" link. That has a "Set as Boot Device" button. What the hell is that for? Didn't selecting / as a mount point (with no separate /boot partition) define my boot device?

14) OK, so Continue must be the next step. 

15) Installation Options. Wait, I already defined my partition layout, but the only way to continue is a "Reclaim Space" button. WTF?

16) Now I'm back at the partitioning screen, with no errors shown. What could be wrong? I defined / (15GB), /home (692 GB), and swap (8 GB). Nothing else is required, so why can't I continue? And why doesn't the UI display the real error message?

Maybe you should hire the developer(s) of gparted. THEY know know to develop an intuitive partitioning UI.

Screw this. I'll stick with F17, and hope that F19 is better. 

Additional info:
Comment 1 Chris Lumens 2013-01-30 10:07:49 EST
Sorry, but we are not dealing with rants disguised as bug reports, especially not rants with cursing and ad hominem attacks and the like.  And in general, we need bugs to have a single issue in them for ease of tracking purposes.  Anything else is pretty much impossible to follow.  I'll just give you a couple general comments:

First, did you read the help text available by clicking on the help button?  It's in the small row of buttons displayed underneath the mountpoints.  That might help some of your confusion somewhat.

Second, of course the filesystem option is insensitive until you check reformat.  Picking a filesystem without reformatting doesn't make any sense.

Third, I've cleaned up some of the confusion about the buttons and what will and won't be touched post-F18, but basically if you didn't select a drive on that first storage screen, it won't be touched.

Fourth, "Set as Boot Device" defines which drive has the first stage of the bootloader written to it, which is completely separate from /boot.

And finally (and what appears to be your real problem here) - you didn't define a /boot.  That's almost certainly why you can't continue with partitioning.  anaconda displays an error bar at the bottom and tells you to click on it for the complete error message.  Did you click on it?  If so, it probably would have told you that you needed to make a /boot.
Comment 2 Tom 2013-01-30 16:09:41 EST
1) A separate /boot partition is not required. Defining / without defining /boot should put /boot on the same partition as /. Besides, even if that is the problem, the UI should tell me that. Only college drop-outs write "there was an error" as the error message.

2) I've never met a programmer who's goal was to frustrate their users. Anaconda accomplishes exactly that. There are a ton of posts online from other users complaining about this "improvement." Smart programmers listen to their users.

3) Choosing not to fix a bug just because you don't like how the bug was submitted is a wee bit childish, but it is your choice. Users that don't like anaconda also have a choice, which is to choose another distro. The custom partitioning is broken in both F17 and F18, so I will probably switch to another distro the next time I am ready for an upgrade. In the meantime, kudos for getting a piece of junk implemented into production software.
Comment 3 Máirín Duffy 2013-01-30 16:31:46 EST
"Only college drop-outs write "there was an error" as the error message."

That's a good one. Tee hee hee, ha ha ha. I have one for you:

Only childish people with poor social skills think that acting like a mean bully in a bug report is going to illicit any kind of sympathy from the developers involved in feeling a twinge of motivation to listen to what you have to say and make changes on it.

There's a lot of folks who've reported bugs with the new interface who had the self-control to use polite language when reporting them. I'm pretty sure they've got a better chance of being listened to than you.
Comment 4 Adam Williamson 2013-01-30 16:37:12 EST
Tom: missing /boot is not likely to be the problem, no, but we cannot possibly guess what the problem is if you don't click on the error message and tell us what it says, or attach logs, or something. We are not telepathic.

At a wild guess, you may be doing a native UEFI install - in which case you need an EFI system partition - or installing to a GPT-labelled disk - in which case you need to create a BIOS boot partition.
Comment 5 Steve Tyler 2013-01-30 17:29:31 EST
Let's start with:

1. A screenshot of the Manual Partitioning dialog with the Unknown partitions list expanded, so we can see what the installer is presenting. When running a Live image, you can press PrintScrn to take a screenshot -- the file is saved in ~/Pictures.

2. The installer logs from /tmp, so we can see all the details.

3. The output from:
   $ lsblk -mf # So we can see what your current storage configuration is.
Comment 6 Wilbert Isaac Cortés González 2013-01-30 17:34:23 EST
Tom do you ever have heard about Rivotril or some "benzo"?, take a pill and chill out! I have some complaints but I don't use that language but they're to specific and subjective, it's my appreciation (about to have the ability to choose one by one the packages I want to install) but just that I don't think it's enough to start a flame-war about some not-a-really-bug-indeed report, it does not have any sense.

Therefore it's not a stupid UI it's a different UI. I was really confuse at first, but it became really intuitive after some setps back and then some steps forward I beg to the Anaconda's team please include it for the next release of fedora.
Comment 7 Wilbert Isaac Cortés González 2013-01-30 17:41:37 EST
(In reply to comment #6)
> Tom do you ever have heard about Rivotril or some "benzo"?, take a pill and
> chill out! I have some complaints but I don't use that language but they're
> to specific and subjective, it's my appreciation (about to have the ability
> to choose one by one the packages I want to install) but just that I don't
> think it's enough to start a flame-war about some not-a-really-bug-indeed
> report, it does not have any sense.
> 
> Therefore it's not a stupid UI it's a different UI. I was really confuse at
> first, but it became really intuitive after some setps back and then some
> steps forward I beg to the Anaconda's team please include it for the next
> release of fedora.

I blew it, I writed very bad; but I guess you can understand my idea/point.
Comment 8 Steve Tyler 2013-01-30 17:53:45 EST
(In reply to comment #0)
...
> 9) Filling up the entire screen with the UI on a 17" screen creates a ton of
> white space that adds to the confusion.
...

What is your display resolution?
Could you attach a screenshot showing the white space?
What is confusing about the white space?

I just noticed you are using the XFCE Spin (Comment 0).
Is XFCE your usual desktop environment?
Comment 9 Steve Tyler 2013-01-30 18:15:00 EST
(In reply to comment #0)
...
> Maybe you should hire the developer(s) of gparted. THEY know know to develop
> an intuitive partitioning UI.
...

I agree that gparted is an excellent GUI partitioning tool. Have you ever used gparted to pre-partition a storage device before installation?

Note You need to log in before you can comment on or make changes to this bug.