Bug 9058 - logrotate configuration problem
logrotate configuration problem
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: junkbuster (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-01 22:21 EST by mck
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-02 12:22:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mck 2000-02-01 22:21:03 EST
Someone must have seen this one but it reappears in each new version,
so I'll make an "official" report.  The following file is included in the
rpm as junkbuster.logrotate to be placed in /etc/logrotate.d:

# Logrotate file for Junkbuster RPM

/var/log/junkbuster/* {
	compress
        weekly
}

Specifying * as the file(s) to be rotated results in a geometric growth
of the number of files in /var/log/junkbuster because each run of
logrotate rotates each _generation_ of the log file instead of just the
base file.   The corrected configuration file should, of course, look
like this:

# Logrotate file for Junkbuster RPM

/var/log/junkbuster/junkbuster{
	compress
        weekly
}
Comment 1 Tim Powers 2000-02-02 12:22:59 EST
OK. I have patched to fix the problem. You should see it in rawhide soon.

Tim

Note You need to log in before you can comment on or make changes to this bug.