Bug 905801 - Include keystone_authtoken in quantum.conf
Include keystone_authtoken in quantum.conf
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-quantum (Show other bugs)
2.1
Unspecified Unspecified
high Severity medium
: snapshot4
: 2.1
Assigned To: Bob Kukura
Ofer Blaut
: Triaged
Depends On:
Blocks: quantum_ovs_tracker
  Show dependency treegraph
 
Reported: 2013-01-30 02:52 EST by Mark McLoughlin
Modified: 2016-04-26 21:05 EDT (History)
8 users (show)

See Also:
Fixed In Version: 2012.2.3-4.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 887822
Environment:
Last Closed: 2013-03-21 15:05:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2013-01-30 02:52:27 EST
+++ This bug was initially created as a clone of Bug #887822 +++

+++ This bug was initially created as a clone of Bug #887334 +++


  6) In our default /etc/quantum/quantum.conf we should also document the 
     [keystone_authtoken] section and put the keystone_authtoken defaults
     in /usr/share/quantum/quantum-dist.conf

 - Don't forget the [keystone_authtoken] ... that should also go in quantum.conf
   and its defaults in quantum-dist.conf


--- Additional comment from Bob Kukura on 2013-01-29 21:44:35 EST ---

Mark,

I'm not sure about the [keystone_authtoken] config you refer to. I don't see that used in the quantum source, except the l3_agent config above that does not use that config section.

-Bob

----

keystone_authtoken options are registered by the authtoken middleware

See also bug #876763 and bug #888725
Comment 2 Bob Kukura 2013-02-22 14:14:16 EST
Fixed in dist-git packaging.
Comment 6 errata-xmlrpc 2013-03-21 15:05:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0672.html

Note You need to log in before you can comment on or make changes to this bug.