Bug 905825 - PamConfig schema not updated during upgrade
Summary: PamConfig schema not updated during upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base
Version: 6.4
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: ---
Assignee: Rich Megginson
QA Contact: Sankar Ramalingam
URL:
Whiteboard:
Depends On:
Blocks: 910994
TreeView+ depends on / blocked
 
Reported: 2013-01-30 09:12 UTC by Ján Rusnačko
Modified: 2013-11-21 21:00 UTC (History)
6 users (show)

Fixed In Version: 389-ds-base-1.2.11.15-14.el6_4
Doc Type: Bug Fix
Doc Text:
After an upgrade from Red Hat Enterprise Linux 6.3 to version 6.4, the upgrade script did not update schema file for the PamConfig object class. Consequently, new features for PAM such as configuration of multiple instances and pamFilter attribute could not be used because of the schema violation. With this update, the upgrade script updates the schema file for the PamConfig object class and new features function properly.
Clone Of:
Environment:
Last Closed: 2013-11-21 21:00:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1653 normal SHIPPED_LIVE 389-ds-base bug fix update 2013-11-20 21:53:19 UTC

Description Ján Rusnačko 2013-01-30 09:12:13 UTC
Description of problem:
After upgrade from RHEL 6.3 to RHEL 6.4, upgrade script is not updating schema file for PamConfig objectClass. This means that new features for PAM like configuration of multiple instances and pamFilter attribute are not possible due to schema violation.

Version-Release number of selected component (if applicable):
389-ds-base-1.2.11.15-11

Steps to Reproduce:
1. Upgrade from 1.2.10.2-15 (RHEL 6.3) to 1.2.11.15-11 (RHEL 6.4)
2. Check the schema for pamConfig:

objectClasses: ( 2.16.840.1.113730.3.2.318 NAME 'pamConfig' DESC 'PAM plugin configuration' SUP top AUXILIARY MAY ( pamMissingSuffix $ pamExcludeSuffix $ pamIncludeSuffix $ pamIDAttr $ pamIDMapMethod $ pamFallback $ pamSecure $ pamService ) X-ORIGIN 'Red Hat Directory Server' ) 

Expected results:
When  1.2.11.15-11 is installed, not upgraded, schema for pamConfig looks like this:

objectClasses: ( 2.16.840.1.113730.3.2.318 NAME 'pamConfig' DESC 'PAM plugin configuration' SUP top AUXILIARY MAY ( cn $ pamMissingSuffix $ pamExcludeSuffix $ pamIncludeSuffix $ pamIDAttr $ pamIDMapMethod $ pamFallback $ pamSecure $ pamService $ pamFilter ) X-ORIGIN 'Red Hat Directory Server' ) 

Note that cn and pamFilter attribute are missing after upgrade.

Comment 5 Ján Rusnačko 2013-08-26 14:04:07 UTC
After upgrade from RHEL 6.3 with 1.2.10.2-15 to RHEL 6.4 with 389-ds-base-1.2.11.15-22 :

[root@dstet schema]# diff 60pam-plugin.ldif ../schema.bak/60pam-plugin.ldif 
51,52c51
< attributeTypes: ( 2.16.840.1.113730.3.1.2131 NAME 'pamFilter' DESC 'Filter to match entries that should use PAM authentication' SYNTAX 1.3.6.1.4.1.1466.115.121.1.15 SINGLE-VALUE X-ORIGIN 'Red Hat Directory Server' )
< objectClasses: ( 2.16.840.1.113730.3.2.318 NAME 'pamConfig' DESC 'PAM plugin configuration' SUP top AUXILIARY MAY ( cn $ pamMissingSuffix $ pamExcludeSuffix $ pamIncludeSuffix $ pamIDAttr $ pamIDMapMethod $ pamFallback $ pamSecure $ pamService $ pamFilter ) X-ORIGIN 'Red Hat Directory Server' )
---
> objectClasses: ( 2.16.840.1.113730.3.2.318 NAME 'pamConfig' DESC 'PAM plugin configuration' SUP top AUXILIARY MAY ( pamMissingSuffix $ pamExcludeSuffix $ pamIncludeSuffix $ pamIDAttr $ pamIDMapMethod $ pamFallback $ pamSecure $ pamService ) X-ORIGIN 'Red Hat Directory Server' )

Verified.

Comment 6 errata-xmlrpc 2013-11-21 21:00:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1653.html


Note You need to log in before you can comment on or make changes to this bug.