Bug 905867 - class-pop3.php missing from wordpress-3.5-3.fc18.noarch
Summary: class-pop3.php missing from wordpress-3.5-3.fc18.noarch
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wordpress
Version: 18
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Remi Collet
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-30 11:01 UTC by Tibbs Brookside
Modified: 2018-04-11 17:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-28 06:56:52 UTC


Attachments (Terms of Use)

Description Tibbs Brookside 2013-01-30 11:01:03 UTC
Description of problem:

wp-mail.php fails with :

PHP Warning: require_once(/usr/share/wordpress/wp-includes/class-pop3.php): failed to open stream: No such file or directory in /usr/share/wordpress/wp-mail.php on line 20
PHP Fatal error: require_once(): Failed opening required '/usr/share/wordpress/wp-includes/class-pop3.php' (include_path='.:/usr/share/pear:/usr/share/php') in /usr/share/wordpress/wp-mail.php on line 20

Version-Release number of selected component (if applicable):

wordpress-3.5-3.fc18.noarch

How reproducible:

100%

Steps to Reproduce:
1. install fedora 18 64-bit
2. install wordpress from default repo
3. run the wp-mail.php script
  
Actual results:

script fails

Expected results:

script should run "Post via e-mail" function (http://codex.wordpress.org/Post_to_y...og_using_email)

Additional info:

Comment 1 Remi Collet 2013-01-30 12:10:51 UTC
Is php-PHPMailer ? (should be pulled by dependency)

Haven't you, in /usr/share/wordpress/wp-includes/ ?

class-phpmailer.php -> /usr/share/php/PHPMailer/class.phpmailer.php
class-pop3.php -> /usr/share/php/PHPMailer/class.pop3.php
class-smtp.php -> /usr/share/php/PHPMailer/class.smtp.php

Comment 2 Tibbs Brookside 2013-01-30 12:24:50 UTC
php-PHPMailer-5.2.2-1.fc18.noarch is installed but i don't have the symbolic links. how should they have been created ?

Comment 3 Remi Collet 2013-01-30 12:31:24 UTC
The symbolic links are include in the package... hum...

please
   rpm --query  wordpress
   rpm --verify wordpress

Comment 4 Remi Collet 2013-01-30 12:41:00 UTC
Hmmm.. seems the build is broken

I don't understand why the package still contains the broken link
/usr/share/wordpress/wp-includes/*php

While this is fixed in -3 release...

In all case the next build (3.5.1 for security) will fix this.

Comment 5 Tibbs Brookside 2013-01-30 12:43:27 UTC
thanks for confirming.

Comment 6 Remi Collet 2013-01-30 12:47:31 UTC
@mcepl : seems there is a git merge problem

$ diff wordpress-3.5-3.fc18.src/wordpress.spec wordpress-3.5-3.fc19.src/wordpress.spec
118,121d117
< # Remove bundled PHPMailer and link to system one
< rm -f ${RPM_BUILD_ROOT}%{_datadir}/wordpress/wp-includes/class-{phpmailer,smtp,pop3}.php
< ln -sf /usr/share/php/PHPMailer/*php ${RPM_BUILD_ROOT}%{_datadir}/wordpress/wp-includes/
< 


I will try to update (3.5.1) and sync branch later today.

Comment 7 Fedora Update System 2013-01-30 16:40:25 UTC
wordpress-3.5.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/wordpress-3.5.1-1.fc18

Comment 8 Fedora Admin XMLRPC Client 2013-01-30 16:54:28 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 9 Fedora Update System 2013-02-01 17:07:33 UTC
Package wordpress-3.5.1-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wordpress-3.5.1-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1774/wordpress-3.5.1-1.fc18
then log in and leave karma (feedback).

Comment 10 Tibbs Brookside 2013-02-05 09:47:04 UTC
have updated the package as requested. running the wp-mail.php script now throws the following error :

PHP Fatal error:  Call to undefined method POP3::user() in /usr/share/wordpress/wp-mail.php on line 39

Comment 11 Fedora Update System 2013-02-10 04:25:26 UTC
wordpress-3.5.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Tibbs Brookside 2013-02-11 14:53:44 UTC
as per comment #10, although the package now includes the symbolic links, the wp-mail.php script fails. i don't really know php so some of the terms i'm about to use may be incorrect but, this appears to be because there is no function called "user" in the POP3 class of the file linked to from the php-PHPMailer package. having looked at the files i took a guess and changed the call in wp-mail.php from POP3->user to POP3>login. the script now runs but throws a :
Server reported an error: -ERR Authentication failed.
error even though i know the credentials are correct (tested via telnet).

Comment 13 Remi Collet 2013-02-12 11:07:11 UTC
Found: pop3 class is not the one from PHPMailer, but another from SquirrelMail.

Currently building 3.5.1-2 which fixes fix issue.

Comment 14 Fedora Update System 2013-02-12 11:31:54 UTC
wordpress-3.5.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/wordpress-3.5.1-2.fc18

Comment 15 Fedora Update System 2013-02-12 11:33:10 UTC
wordpress-3.5.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/wordpress-3.5.1-2.fc17

Comment 16 Fedora Update System 2013-02-13 04:24:57 UTC
Package wordpress-3.5.1-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wordpress-3.5.1-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2343/wordpress-3.5.1-2.fc17
then log in and leave karma (feedback).

Comment 17 Tibbs Brookside 2013-02-14 12:14:38 UTC
i can confirm that the latest updates has resolved the problems for me and the "Post via e-mail" function is working again.

i can't say i understand why the class-pop3.php file has had to be taken from squirrelmail when wordpress supplies this file natively.

Comment 18 Fedora Update System 2013-02-28 06:56:54 UTC
wordpress-3.5.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2013-02-28 07:10:21 UTC
wordpress-3.5.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.