Bug 90589 - RPM Database corruption after upgrade
RPM Database corruption after upgrade
Status: CLOSED DUPLICATE of bug 90560
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-09 18:45 EDT by Mike H.
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike H. 2003-05-09 18:45:57 EDT
Description of problem:
Today I upgrade from rh8 and rh9 and in the process my rpm database has become 
corrupted. If I try to remove packages or install packages, sometimes I get an 
rpm corruption error.


Version-Release number of selected component (if applicable):
rpm 4.2


How reproducible: often 


Steps to Reproduce:
1. rpm -ivh package
2.
3.
    
Actual results: corruption error


Expected results: package to install or remove


Additional info:[root@dhcp-1577-8 rpms]
# /usr/lib/rpm/rpmdb_verify /var/lib/rpm/Packages
db_verify: Page 387: bad page number 1792
db_verify: Page 387: invalid prev_pgno 17152
db_verify: page 388: illegal page type or format
db_verify: PANIC: Invalid argument
db_verify: /var/lib/rpm/Packages: pgin failed for page 388
db_verify: fatal region error detected; run recovery
db_verify: fatal region error detected; run recovery
db_verify: fatal region error detected; run recovery
db_verify: fatal region error detected; run recovery
db_verify: DB->verify: /var/lib/rpm/Packages: DB_VERIFY_BAD: Database 
verification failed
db_verify: fatal region error detected; run recovery
db_verify: fatal region error detected; run recovery
db_verify: dbenv->close: DB_RUNRECOVERY: Fatal error, run database recovery
[root@dhcp-1577-8 rpms]# rpm --rebuilddb
error: rpmdbNextIterator: skipping h#      64 blob size(6428): BAD, 8 + 16 * il
(1946186351) + dl(1869873266)
error: rpmdbNextIterator: skipping h#      61 region trailer: BAD, tag 35378 
type 21234358 offset -2025055918 count 574090562
error: rpmdbNextIterator: skipping h#      63 blob size(8984): BAD, 8 + 16 * il
(1946186351) + dl(1869873266)
error: rpmdbNextIterator: skipping h#      65 blob size(9252): BAD, 8 + 16 * il
(1946186351) + dl(1869873266)
error: rpmdbNextIterator: skipping h#      67 blob size(12852): BAD, 8 + 16 * 
il(1946186351) + dl(1869873266)
error: rpmdbNextIterator: skipping h#      62 blob size(7748): BAD, 8 + 16 * il
(1375731742) + dl(1375731743)
error: rpmdbNextIterator: skipping h#      66 blob size(7808): BAD, 8 + 16 * il
(1946186351) + dl(1869873266)
error: db4 error(16) from dbenv->remove: Device or resource busy
Comment 1 Jeff Johnson 2003-05-09 19:15:15 EDT
Use the procedure in duplicated bug to fix.

*** This bug has been marked as a duplicate of 90560 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:52:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.