This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 905924 - spmStart throws a MetaDataKeyNotFoundError exception while upgrading a domain from v2 to v3 due to a partially removed volume (lv present, metadata blanked).
spmStart throws a MetaDataKeyNotFoundError exception while upgrading a domain...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.4
All Other
urgent Severity urgent
: rc
: 6.4
Assigned To: Federico Simoncelli
Dafna Ron
storage
: ZStream
Depends On: 902838
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-30 08:36 EST by Idith Tal-Kohen
Modified: 2013-02-25 14:09 EST (History)
16 users (show)

See Also:
Fixed In Version: vdsm-4.10.2-1.3.el6
Doc Type: Bug Fix
Doc Text:
Previously, when a logical volume's metadata was blank and it was removed from the engine, attempts to upgrade the associated storage domain from version 2 to version 3 failed. This was due to an uncaught MetaDataKeyNotFoundError exception. A workaround has been introduced whereby logical volumes are renamed using "lvrename" and LV tags are removed from logical volumes by means of "lvchange --deltag". Upgrading storage domains from version 2 to version 3 now works correctly even in cases where previously the MetaDataKeyNotFoundError would previously have been triggered.
Story Points: ---
Clone Of: 902838
Environment:
Last Closed: 2013-02-25 14:09:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 297213 None None None Never
oVirt gerrit 11281 None None None Never

  None (edit)
Comment 3 Dafna Ron 2013-02-20 08:36:45 EST
verified on vdsm-4.10.2-1.5.el6.x86_64
Comment 5 errata-xmlrpc 2013-02-25 14:09:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0555.html

Note You need to log in before you can comment on or make changes to this bug.