Bug 90595 - Using Belkin 4 port ps2/vga hub. If I switch to the other system then back, lose control of mouse. Windows flash, programs execute as mouse moves around on it's own.
Using Belkin 4 port ps2/vga hub. If I switch to the other system then back, ...
Status: CLOSED DUPLICATE of bug 89948
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-10 00:47 EDT by Chad
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chad 2003-05-10 00:47:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705; .NET CLR 1.1.4322)

Description of problem:
Using Belkin 4 port ps2/vga hub.  Allows to connect to pc towers with one 
mouse, one monitor and one keyboard.  If I switch to the other system then 
back, I lose control of mouse.  Windows flash, programs execute as mouse moves 
around on it's own.  Same thing happens if only use the hub with the keyboard 
and monitor and plug a mouse directly into the PS2 port. Correctsable with 
reboot or with ctrl + ALT + backspace

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. with belkin hub system desribed above, change to other system hitting 
button on hub.
2.Change back to linux system
3.watch the mouse freak out
    

Actual Results:  Lost mouse control.

Expected Results:  system should respond as normal.  Should be able to switch 
between boxes with no interuption.

Additional info:

Found a lot of people with similar trouble - google search for "KVM switch 
mouse goes crazy with linux" (without the quotes)
Comment 1 Chad 2003-05-11 12:20:19 EDT
Found fix on google - "If you're working in X-Windows, hit Ctrl+Alt+[F1-F6] to 
go to a virtual console, and then Alt+F7 to return to X. If you're at a 
console, do the opposite: Hit Alt+F7 to jump to X-Windows, then Ctrl+Alt+[F-
console number] to return." from www-net.cs.umass.edu/cs591_fall02/faq.html
Comment 2 Brent Fox 2003-05-12 10:53:25 EDT
Changing component to XFree86.
Comment 3 Mike A. Harris 2003-05-13 05:03:16 EDT
This problem may, or may not be able to be worked around via software hacks.
If it is possible, and it may not be, it would require physical access to
both the problematic KVM switch and the exact mouse model (or some mouse
model) which is observing this behavior.

You may wish to file a bug report about this problem upstream at
http://bugs.xfree86.org in case someone in the larger community whom has this
hardware and is able to reproduce the problem might be able to also produce
an XFree86 software hack workaround.

Closing this bug as a duplicate of our KVM master bug.  Please read through
the master bug report for complete details about KVM related problems and
support.



*** This bug has been marked as a duplicate of 76124 ***
Comment 4 Mike A. Harris 2003-05-13 05:04:37 EDT
Oops, I got the wrong bug dupe above.  It is this one:

*** This bug has been marked as a duplicate of 89948 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:52:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.