Bug 90597 - Unable to install Net::SSLeay from CPAN; "could not locate your pod2man program"
Unable to install Net::SSLeay from CPAN; "could not locate your pod2man program"
Status: CLOSED DUPLICATE of bug 87682
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-10 03:04 EDT by Les Bell
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Les Bell 2003-05-10 03:04:32 EDT
The CPAN module configured correctly, using "perl -M CPAN -e shell".

However, when the command "install Net::SSLeay" is given, the install of the
module fails:
Warning: I could not locate your pod2man program. Please make sure,
         your pod2man program is in your PATH before you execute 'make'

Writing Makefile for Net::SSLeay::Handle

Warning: I could not locate your pod2man program. Please make sure,
         your pod2man program is in your PATH before you execute 'make'

Writing Makefile for Net::SSLeay
Makefile:88: *** missing separator.  Stop.
  /usr/bin/make  -- NOT OK
  CPAN.pm: Going to build S/SA/SAMPO/Net_SSLeay.pm-1.22.tar.gz

Checking for OpenSSL-0.9.6g or newer...
You have OpenSSL-0.9.7a installed in /usr
That's is newer than what this module was tested with (0.9.6g). You should
consider checking if there is a newer release of this module
available. Everything will probably work OK, though.
*** Could not figure out which C compiler was used to compile /usr/bin/openssl.
It is essentiall that OpenSSL, perl, and Net::SSLeay are compiled with the same
compiler and flags. Mixing and matching compilers is not supported. at
Makefile.PL line 132.
Checking if your kit is complete...
Looks good
Checking if your kit is complete...
Looks good

Warning: I could not locate your pod2man program. Please make sure,
         your pod2man program is in your PATH before you execute 'make'

Writing Makefile for Net::SSLeay::Handle

Warning: I could not locate your pod2man program. Please make sure,
         your pod2man program is in your PATH before you execute 'make'

Writing Makefile for Net::SSLeay
Makefile:88: *** missing separator.  Stop.
  /usr/bin/make  -- NOT OK
Running make test
  Can't test without successful make
Running make install
  make had returned bad status, install seems impossible

Expected Results:  Module should have compiled and installed normally - I've
done this dozens of times on RH 7.x and 8.

Additional info:

We need to install Net::SSLeay as a prerequisite to running Webmin-1.080-1 over
an SSL connection. With no SSL support, we cannot expose Webmin on
Internet-accessible hosts, so this is a security-related show-stopper. We cannot
deploy RH 9 without this.
Comment 1 Chip Turner 2003-05-12 11:07:01 EDT

*** This bug has been marked as a duplicate of 87682 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:52:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.