Bug 906009 - libvirt-guests fails to restart guests at boot time
libvirt-guests fails to restart guests at boot time
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-30 10:46 EST by Alan Jenkins
Modified: 2013-12-30 20:55 EST (History)
13 users (show)

See Also:
Fixed In Version: libvirt-1.1.3.2-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-30 20:55:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alan Jenkins 2013-01-30 10:46:00 EST
Description of problem:

libvirt-guests fails to restart guests at boot time.  The journal shows it failing to connect to libvirtd.


Version-Release number of selected component (if applicable):

libvirt-0.10.2.2-3.fc18.x86_64
(installed from testing, fixes libvirt crash on system shutdown a.k.a. bug 903184)

How reproducible: always

Steps to Reproduce:
1. systemctl enable libvirt-guests
2. start a guest system
3. reboot
  
Actual results:

After the reboot, the guest system is shown as "saved" in virt-manager.

Expected results:

After the reboot, the guest system should be running.

Additional info:

- On a running system, you can stop, and then start libvirt-guests, and it has the expected result.  I.e. the guest is saved, and then resumed.

- Log messages:

libvirt-guests.service - Suspend Active Libvirt Guests
          Loaded: loaded (/usr/lib/systemd/system/libvirt-guests.service; enabled)
          Active: active (exited) since Wed 2013-01-30 15:17:11 GMT; 18min ago
         Process: 1279 ExecStart=/etc/init.d/libvirt-guests start (code=exited, status=0/SUCCESS)

Jan 30 15:17:11 fossil.scree.dyndns.org systemd[1]: Starting Suspend Active Libvirt Guests...
Jan 30 15:17:11 fossil.scree.dyndns.org libvirt-guests[1279]: Can't connect to default. Skipping.
Jan 30 15:17:11 fossil.scree.dyndns.org systemd[1]: Started Suspend Active Libvirt Guests.
Comment 1 Alan Jenkins 2013-01-30 11:40:44 EST
I noticed guests didn't start at boot-time on F17 either.  I didn't look for the error message at the time, but I can reproduce the exact same error message in an F17 VM.  (It looks like you can't nest KVM, so the inner VM was run under QEMU).
Comment 2 Cole Robinson 2013-04-01 14:01:44 EDT
I rebooted a few times and managed to reproduce this once. Might be a race with libvirtd starting up, if libvirt-guests tries to connect to early, the check fails and no guests are started.
Comment 3 Zbigniew Jędrzejewski-Szmek 2013-11-18 09:47:15 EST
It seems that libvirt-guests.service has no dependency on libvirtd.service. It should probably have After=libvirtd.service.
Comment 4 Eric Blake 2013-11-18 10:46:44 EST
Might be related to bug 1031696
Comment 5 Cole Robinson 2013-11-19 15:23:18 EST
I've sent a patch upstream with the suggestion in Comment #3
Comment 6 Cole Robinson 2013-11-20 09:04:32 EST
Upstream now:

commit d92036754a70098377798d93cb6d20378959e3a7
Author: Cole Robinson <crobinso@redhat.com>
Date:   Tue Nov 19 15:19:25 2013 -0500

    libvirt-guests: Run only after libvirtd


And pushed to F19 and F20 maint
Comment 7 Fedora Update System 2013-12-14 16:34:19 EST
libvirt-1.1.3.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libvirt-1.1.3.2-1.fc20
Comment 8 Fedora Update System 2013-12-16 02:07:39 EST
Package libvirt-1.1.3.2-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libvirt-1.1.3.2-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23446/libvirt-1.1.3.2-1.fc20
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-12-30 20:55:41 EST
libvirt-1.1.3.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.