Bug 90602 - Using Neat with tokenring results in hang on shutdown
Using Neat with tokenring results in hang on shutdown
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-10 09:07 EDT by Martijn Lievaart
Modified: 2014-03-16 22:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: 7.85-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 16:09:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martijn Lievaart 2003-05-10 09:07:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211

Description of problem:
Neat inserts the HWADDR in the ifcfg file, but /sbin/if(up|down) cannot handle
tokenring correctly.

This would not be a big deal (workaround, remove HWADDR line from ifcfg file),
if it did not hang the machine on shutdown.


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
Note: I have had this problem more often, but have currently no access to a
token ring network.
1. Use neat to configure your tokenring card
2. shutdown

    

Actual Results:  Hang on the shutdown of the network

Expected Results:  Machine should have gone down.

Additional info:

From /sbin/ifdown (also in ifup)

if [ -n "${HWADDR}" ]; then
    FOUNDMACADDR=`LC_ALL= LANG= ip -o link show ${REALDEVICE} | \
        sed 's/.*link\/ether \([[:alnum:]:]*\).*/\1/'`
    if [ "${FOUNDMACADDR}" != "${HWADDR}" ]; then

The problem is that neat inserts your HWADDR in the ifcfg-tr0. The above line
only searches for ethernet hardware addresses. The result is that shutdown
hangs. (I have no clue how NEAT can get the device up in the first place).

Solution would be to replace 'ether' with something like '[^ ]*'
Comment 1 Bill Nottingham 2004-09-27 16:09:17 EDT
Fixed, will be in 7.85-1.

Note You need to log in before you can comment on or make changes to this bug.