Bug 90604 - file-detect.el library missing
Summary: file-detect.el library missing
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apel   
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-10 16:14 UTC by Marko Grvnroos
Modified: 2015-01-08 00:05 UTC (History)
2 users (show)

Fixed In Version: 10.4-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-22 09:49:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to re-enable file-detect.el (399 bytes, patch)
2003-05-12 12:13 UTC, Jens Petersen
no flags Details | Diff

Description Marko Grvnroos 2003-05-10 16:14:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
file-detect.el is missing (and file-detect.elc is probably useful too).

At least the "gnus" news reader package in XEmacs (and Emacs) requires it for
saving news articles, and reports error if the file is not available.


Version-Release number of selected component (if applicable):
xemacs-21.4.12-6

How reproducible:
Always

Steps to Reproduce:
1. Run xemacs
2. Start gnus
3. Subscribe to newsgroup
4. Read articles
5. Press "o" to save an article
6. Press enter to accept the suggested file name for saving

    

Actual Results:  File is not saved, gnus reports error "Cannot open load file:
file-detect" in the mini-window in bottom of screen.


Expected Results:  Article should have been saved in news save folder, no error.

Additional info:

I found the missing file-detect.el from "tm" RPM package available from
rpmfind.net, though the particular RPM was not compatible with RH9 and the file
was put in wrong directory.

Comment 1 Jens Petersen 2003-05-12 12:09:49 UTC
It seems tm requires "file-detect.el", which is deprecated in current apel.
So can we please bring it back at least for apel-xemacs?

Comment 2 Jens Petersen 2003-05-12 12:13:06 UTC
Created attachment 91615 [details]
patch to re-enable file-detect.el

Comment 3 Marko Grvnroos 2003-05-12 13:36:55 UTC
Apparently also atype.el seems to be necessary to get the saving articles
working, at least in some cases (not sure why I didn't notice it in the first
time). After that, it seems to work properly.


Comment 4 Akira TAGOH 2003-05-22 09:49:07 UTC
fixed.


Note You need to log in before you can comment on or make changes to this bug.