Bug 906080 - authentication is required to poweroff machine when only one user is logged in
authentication is required to poweroff machine when only one user is logged in
Status: CLOSED DUPLICATE of bug 890827
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-30 14:42 EST by cornel panceac
Modified: 2013-01-30 17:37 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-30 17:37:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description cornel panceac 2013-01-30 14:42:48 EST
Description of problem:
On systems that have exactly one user each, attempting to power off the machine requires to enter a password, pretending that many users are logged in.
This is not a problem but only a hassle for an advanced user, who understands what's going on, but a regular user prefers to cut the power to the system than try in vain to understand what is going on.

Version-Release number of selected component (if applicable):


How reproducible:
way too often

Steps to Reproduce:
1.login to gnome, browse internet, watch some pictures
2.attempt to power off
3.
  
Actual results:


Expected results:


Additional info:
this is usually reproduced in fallback mode of gnome, since -shell is mostly unusable on computers not very powerfull. (like athlon 64 3200+, with 1GB RAM, nvidia 6200 video card, 80 gb WDC hard disk)
Comment 1 Bill Nottingham 2013-01-30 17:21:54 EST
What's the output of 'loginctl' when this happens?
Comment 2 Michal Schmidt 2013-01-30 17:37:59 EST
When you do that, you'll probably find a cron session running anacron running one of its random-length sleep processes.

Please give systemd-197-1.fc18.2 from updates-testing a try.
https://admin.fedoraproject.org/updates/FEDORA-2013-1590/systemd-197-1.fc18.2

As noted in the update description:
> logind will ignore non-tty/non-X11 sessions when checking for other
> sessions before shutdown.

This is bug 890827. Closing as a duplicate. Reopen if I'm wrong about this.

*** This bug has been marked as a duplicate of bug 890827 ***

Note You need to log in before you can comment on or make changes to this bug.