Bug 90612 - No option to install extra postgresql packages
No option to install extra postgresql packages
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: comps (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-10 19:37 EDT by Need Real Name
Modified: 2014-03-16 22:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 17:36:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-05-10 19:37:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

Description of problem:
There is no option in the installer to install the extra postgresql packages. At
the very minimum they should be installable in SQL Database Server Package details.

These packages include:

mx-2.0.3-8.i386.rpm
postgresql-7.3.2-3.i386.rpm
postgresql-contrib-7.3.2-3.i386.rpm
postgresql-devel-7.3.2-3.i386.rpm
postgresql-docs-7.3.2-3.i386.rpm
postgresql-jdbc-7.3.2-3.i386.rpm
postgresql-python-7.3.2-3.i386.rpm
... and a bunch more.

Do a rpm -qa | grep postgresql  on Disk2

Version-Release number of selected component (if applicable):
postgresql-*-7.3.2*

How reproducible:
Always

Steps to Reproduce:
1. Run System Settings>Add/Remove Applications
2. Select Details in the SQL Database Server Group
3. They are nowhere to be found except grepping Disk2 for them
    

Actual Results:  They are nowhere to be found.

Expected Results:  The packages should show up in extra packages to be installed.

Additional info:

These packages Don't fit nicely into either SQL Database Server, or Development,
but really should be selectable from somewhere. I would think that they should
at least appear in SQL Database Server.
Comment 1 Michael Fulbright 2003-05-12 15:10:46 EDT
Reassigning to comps, which controls what is visible in each group.
Comment 2 Bill Nottingham 2003-05-18 20:37:10 EDT
postgresql-server brings in the base postgresql package.

mx seems ancillary to postgres.
Comment 3 Need Real Name 2003-05-18 21:58:31 EDT
mx is a dependency on postgresql-python. The main issue is not that any
particular item is ancillary to another. The issue is that there is no way to
install the ancillary packages through Add/Remove Applications. The desire is to
add those packages so they can be installed. 
Comment 4 Bill Nottingham 2004-09-30 17:36:02 EDT
This looks better looking at the current FC3 devel comps file. 

Note You need to log in before you can comment on or make changes to this bug.