Bug 906133 - Test case failure: nm-connection-editor - wireless - set BSSID
Summary: Test case failure: nm-connection-editor - wireless - set BSSID
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager
Version: 6.4
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Dan Williams
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-30 23:24 UTC by Mark Gordon
Modified: 2013-11-21 21:48 UTC (History)
5 users (show)

Fixed In Version: NetworkManager-0.8.1-47.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 21:48:49 UTC


Attachments (Terms of Use)
[PATCH NM master] editor: hiding BSSID for Ad-Hoc connections (4.41 KB, patch)
2013-03-08 19:53 UTC, Jirka Klimes
no flags Details | Diff
[PATCH RHEL 6] editor: hiding BSSID for Ad-Hoc connections (4.67 KB, patch)
2013-03-08 19:55 UTC, Jirka Klimes
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1670 normal SHIPPED_LIVE NetworkManager bug fix and enhancement update 2013-11-21 00:39:32 UTC

Description Mark Gordon 2013-01-30 23:24:15 UTC
Filed from caserun https://tcms.engineering.redhat.com/run/54687/

Version-Release number of selected component (if applicable):
RHEL6.4-20130109.1

Steps to Reproduce: 
Have two laptops or desktops with wireless cards.

Be logged into a GNOME session as a regular user.

Open nm-applet->Edit connections...


 1. Hit Add button
 2. Choose wireless
 3. Connection name set to kockopes
 4. Mode set to Ad-hoc
 5. SSID set to kockopes
 6. BSSID set to 00:11:22:33:44:55
 7. switch to wireless Security tab
 8. choose None
 9. Apply
10. Connect profile via nm-applet
11. Connect from second laptop to kockopec wireless network.



Actual results: 
Ad-hoc network never comes up if a BSSID is specified.

Expected results:
The kockopec network should appear in the list of networks with preconfigured
BSSID.

Comment 2 RHEL Product and Program Management 2013-02-03 06:47:36 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 3 Jirka Klimes 2013-02-08 10:24:13 UTC
It is a misunderstanding. BSSID field in the connection editor is for restricting ("locking") the connection to only the AP with specified BSSID (as indicated in the tooltip). It is not meant to create BSSID for Ad-hoc networks (I admit it could be a bit misleading).

Nonetheless, BSSID is random for ad-hoc  networks. In fact, it is not created by NetworkManager, but in kernel mac80211 subsystem or driver (when Ad-hoc network is created). So, there's no need to specify the BSSID at all.
The code for generating BSSID for IBSS (Ad-hoc) is here:
http://lxr.linux.no/linux+v3.7.6/net/mac80211/ibss.c#L685

Comment 4 Dan Williams 2013-02-25 23:50:15 UTC
Yeah, we should probably just hide the BSSID field for AdHoc connections as we cannot guarantee that it will be honored.

Comment 5 Jirka Klimes 2013-03-08 19:53:23 UTC
Created attachment 707201 [details]
[PATCH NM master] editor: hiding BSSID for Ad-Hoc connections

Patch for hiding BSSID for Ad-Hoc connections.
This is for NM upstream master branch.

Comment 6 Jirka Klimes 2013-03-08 19:55:16 UTC
Created attachment 707202 [details]
[PATCH RHEL 6] editor: hiding BSSID for Ad-Hoc connections

Backport of the previous patch to RHEL 6.x NM.

Comment 7 Dan Williams 2013-03-08 22:32:55 UTC
(In reply to comment #5)
> Created attachment 707201 [details]
> [PATCH NM master] editor: hiding BSSID for Ad-Hoc connections
> 
> Patch for hiding BSSID for Ad-Hoc connections.
> This is for NM upstream master branch.

Looks good, please push to git master and nm-0-9-8.

Comment 8 Dan Williams 2013-03-08 22:33:13 UTC
(In reply to comment #6)
> Created attachment 707202 [details]
> [PATCH RHEL 6] editor: hiding BSSID for Ad-Hoc connections
> 
> Backport of the previous patch to RHEL 6.x NM.

Looks good.

Comment 9 Jirka Klimes 2013-03-11 09:22:33 UTC
(In reply to comment #7)
> (In reply to comment #5)
> > Created attachment 707201 [details]
> > [PATCH NM master] editor: hiding BSSID for Ad-Hoc connections
> > 
> > Patch for hiding BSSID for Ad-Hoc connections.
> > This is for NM upstream master branch.
> 
> Looks good, please push to git master and nm-0-9-8.

fa3a6b876b095d087d7eb179246d78c3d3e58534 (master)
0b93ea3f6139dd46a418a108ee9e01c9098691d9 (nma-0-9-8)

Comment 20 errata-xmlrpc 2013-11-21 21:48:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1670.html


Note You need to log in before you can comment on or make changes to this bug.