Bug 906137 - Slide show mode inverts outputs
Summary: Slide show mode inverts outputs
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice   
(Show other bugs)
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-30 23:56 UTC by Simo Sorce
Modified: 2013-03-24 22:49 UTC (History)
7 users (show)

Fixed In Version: libreoffice-3.6.5.2-8.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 920601 (view as bug list)
Environment:
Last Closed: 2013-03-24 22:49:34 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
demo program (709 bytes, text/plain)
2013-01-31 12:30 UTC, Caolan McNamara
no flags Details

Description Simo Sorce 2013-01-30 23:56:55 UTC
On a T520 laptop, docked and with an external monitor connected via HDMI port on the dock LiberOffice misunderstand what is the internal and what is the external monitor.

If I choose "Display 1" it shows the presentation on the external monitor
If I choose "Display 2 (external)" it shows the presentation on my laptop screen 

In the second case it also fails to conceal the gnome-shell bar so the presentation has the bar overlayed

Comment 1 Caolan McNamara 2013-01-31 12:30:38 UTC
Created attachment 690869 [details]
demo program

Does the "right thing" for me with a laptop that's already running, and then I connect to a projector/monitor afterwards. I get the display 1 as the laptop and the "external" display as the right one.

Can I get the output of gcc `pkg-config --cflags --libs gtk+-2.0` screentest.c && ./a.out

Comment 2 Simo Sorce 2013-01-31 13:44:24 UTC
monitor 0 is called HDMI3
monitor 1 is called LVDS1
monitor 1 is reported to be the primary. Assuming to be the laptop, typically called LVDS

Comment 3 Caolan McNamara 2013-03-12 15:03:21 UTC
For "failing to conceal gnome-shell bar" see bug 920697 and its standalone reproducer.

Comment 4 Caolan McNamara 2013-03-12 16:55:51 UTC
re-reading comment #1, Which monitor is gnome-shell's task-bar on ?

Comment 5 Simo Sorce 2013-03-13 12:43:52 UTC
The taskbar is on the laptop monitor.

Comment 6 Caolan McNamara 2013-03-13 14:24:05 UTC
With a bit of wiggling of xrandr I can get my monitors into the same order as your on one of my laptops and get impress bustage that looks like this.

Comment 7 Caolan McNamara 2013-03-15 11:21:41 UTC
*grrr*, that's super annoying. gmodule thing returned 0 for the symbol we wanted to use, so into the fallback code, and another bug in that so big chain of stuff turns into "monitor 0 is always the laptop"

Comment 8 Fedora Update System 2013-03-15 20:07:39 UTC
libreoffice-3.6.5.2-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libreoffice-3.6.5.2-8.fc18

Comment 9 Fedora Update System 2013-03-17 01:09:03 UTC
Package libreoffice-3.6.5.2-8.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.6.5.2-8.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3975/libreoffice-3.6.5.2-8.fc18
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2013-03-24 22:49:36 UTC
libreoffice-3.6.5.2-8.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.