Bug 906158 - Revise Support for the application/json Format
Revise Support for the application/json Format
Status: CLOSED DUPLICATE of bug 905210
Product: RHQ Project
Classification: Other
Component: REST (Show other bugs)
4.5
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Heiko W. Rupp
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-30 21:55 EST by Fernando Ribeiro
Modified: 2013-02-09 17:19 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-07 04:35:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Fernando Ribeiro 2013-01-30 21:55:56 EST
Description of problem:

When I retrieve the "alert/count" resource in the "application/json" format, for example, the API returns values like "1" (not JSON) instead of "{result=1}" or "[1]" (JSON).

Version-Release number of selected component (if applicable):

4.5.1

How reproducible:

Steps to Reproduce:
1. Retrieve the "alert/count" resource in the "application/json" format
2. Verify that the returned value is not JSON

Actual results:

Expected results:

Additional info:
Comment 1 Heiko W. Rupp 2013-02-07 04:35:38 EST
Not exactly a duplicate, as Bug 905210 talks about xml and this one about Json, but the internal reason is the same.

*** This bug has been marked as a duplicate of bug 905210 ***
Comment 2 Fernando Ribeiro 2013-02-09 17:19:00 EST
Great, thanks!

Note You need to log in before you can comment on or make changes to this bug.