Bug 90617 - New perl modules fail to make when using CPAN
New perl modules fail to make when using CPAN
Status: CLOSED DUPLICATE of bug 87682
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-11 01:00 EDT by Adam H. Pendleton
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam H. Pendleton 2003-05-11 01:00:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b)
Gecko/20030507

Description of problem:
When using CPAN to install new perl modules, the 'make' command fails every time
with a "Makefile:XX: *** missing separator.  Stop." where XX is a line number. 
The following *always* appears at that line, regardless of module:

installhtml3dir=''
**installman1**
INSTALLSITEBIN = /usr

The ** line is the line in question (it does not appear in the file surrounded
by **'s).

perl -MCPAN -e shell
[snip]
cpan> install CDB_File
[snip]
Writing Makefile for CDB_File
Makefile:82: *** missing separator.  Stop.
  /usr/bin/make  -- NOT OK

This section of the Makefile seems to be generated by MakeMaker.  I could not
determine the cause of this problem, so I am reporting it as a bug since it
happens on *all* my RH 9 distributions, and I can't find CDB_File in a RPM.

Version-Release number of selected component (if applicable):
perl-5.8.0-88 perl-CPAN-1.61-88

How reproducible:
Always

Steps to Reproduce:
1. perl -M CPAN -e shell
2. cpan> install CDB_File
3.
    

Actual Results:  [snip]
Writing Makefile for CDB_File
Makefile:82: *** missing separator.  Stop.
  /usr/bin/make  -- NOT OK

Additional info:
Comment 1 Chip Turner 2003-05-12 11:07:07 EDT

*** This bug has been marked as a duplicate of 87682 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:52:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.