Bug 90618 - (USB CPIA)xawtv runs slower in 9 than it did on 7.3
(USB CPIA)xawtv runs slower in 9 than it did on 7.3
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-11 01:08 EDT by Joe Acosta
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:40:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree log file (32.10 KB, text/plain)
2003-05-22 11:41 EDT, Joe Acosta
no flags Details
output from dmesg as well (7.79 KB, text/plain)
2003-05-22 11:42 EDT, Joe Acosta
no flags Details

  None (edit)
Description Joe Acosta 2003-05-11 01:08:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

Description of problem:
I have an athelon 1.2Ghz, with 1/2 Gig RAM.

I run xawtv with my cpia wevcam II from creative and it sends the system to max
CPU and io.  making the system virtually unusable

Version-Release number of selected component (if applicable):
xawtv 3.81 and 3.88

How reproducible:
Always

Steps to Reproduce:
1. get a webcam II 
2. install RH 9
3. run xawtv
    

Actual Results:  system slows to an almost halt

Expected Results:  it should still be usable

Additional info:
Comment 1 Ngo Than 2003-05-13 18:30:56 EDT
strange, i have philips webcam and it works fine for me.
Comment 2 Joe Acosta 2003-05-13 21:45:39 EDT
hmm phillips webcam and creative web cams are different cams.  Are you using the
cpia driver?  Is it parallel port?  I think this is a bug.
Comment 3 Ngo Than 2003-05-14 05:36:38 EDT
which kernel-version do you have on your machine with RHL 7.3?
It could be a bug in kernel driver.
Comment 4 Joe Acosta 2003-05-14 11:39:36 EDT
It was pretty slow on 7.3 and I was using kernel 2.4.20.  On RH 9 I am using
2.4.20 also.

It seems to have gotton slower with th echange from 7.3 to 9, but it was kinda
slow in 7.3.  It was usable though it just took time to come up.  Now it takes
time to come up and it also makes mouse and X movement very slow.  Could this be
related to X? 
Comment 5 Ngo Than 2003-05-22 06:38:23 EDT
Which video card do you have in your machine?

Could you please attach your /etc/X11/XF86Config?

How have you started xawtv? There are some options, which you perhaps try:

     -(no)dga        enable/disable DGA extention
     -(no)vm         enable/disable VidMode extention
     -(no)xv         enable/disable Xvideo extention altogether
     -(no)xv-video   enable/disable Xvideo extention (for video only,
                     i.e. XvPutVideo() calls)
     -(no)xv-image   enable/disable Xvideo extention (for image scaling
                     only, i.e. XvPutImage() calls)


Comment 6 Joe Acosta 2003-05-22 11:41:03 EDT
Created attachment 91897 [details]
XFree log file
Comment 7 Joe Acosta 2003-05-22 11:42:02 EDT
Created attachment 91898 [details]
output from dmesg as well
Comment 8 Joe Acosta 2003-05-22 11:43:43 EDT
I have attached the output from both dmesg and XFree log file of my system.  So
you can see how the parallel port is loaded.

I have tried xawtv -no(u name it switch).  It may not be xawtv, cause I just
tried gqcam and it does the same thing.  This may be a kernel issue or X? 
Comment 9 Joe Acosta 2003-05-23 00:24:00 EDT
I just updated the drivers from webcam.sourceforge.net.  These are the cpia***
files in the kernel and it seems to be working much better now.  
Comment 10 Mike A. Harris 2003-05-23 04:31:50 EDT
This has nothing to do with XFree than
Comment 11 Joe Acosta 2003-05-23 18:33:26 EDT
It seems this is a kernel bug.   Sorry, but I used to know a Mike A Harris, he
lived in CA is this the same one?
Comment 12 Ngo Than 2003-05-26 13:58:08 EDT
ok, i don't think it's a bug in xawtv, because the philips webcams work fine
with xawtv. I assign it to kernel
Comment 13 Joe Acosta 2003-05-26 15:31:04 EDT
One issue with the updated drivers is that now I cannot capture a picture with
xawtv and the webcam II.  I can however capture picture with gqcam.  However if
I use xawtv first and then use gqcam, gqcam does not display a picture correctly
or capture correctly.  However if I use gqcam first I can capture pictures and
use the webcam II pretty well.  So I have stopped using xawtv, in favor of gqcam
or I'll use xsane, as it works okay also. 
Comment 14 Bugzilla owner 2004-09-30 11:40:53 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.