Bug 90621 - during upgrade setup cant mount /dev/sda1
during upgrade setup cant mount /dev/sda1
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-11 05:10 EDT by Michele Ginestra
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-13 12:33:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michele Ginestra 2003-05-11 05:10:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Virgilio6pc)

Description of problem:
I tried to upgrade rh8 to rh9. previously i have added to the rh8 fstab an 
entry for a usb pendrive, /dev/sda1.
during the upgrade anaconda told me that it couldn't mount /dev/sda1 and quit. 
I'd like an option to continue the setup, even if it impossible to mount a 
device.
thanks.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. add an entry to fstab for /dev/sda1
2. make sure there is no /dev/sda1 device connected
3. reboot and upgrade to rh9
    

Additional info:
Comment 1 Michael Fulbright 2003-05-12 15:11:29 EDT
Please attach your /etc/fstab.

At worst you can just comment out the line during the upgrade.
Comment 2 Michele Ginestra 2003-05-12 16:02:49 EDT
unfortunately I've reformatted and reinstalled rh9 from scratch,
since I wasn't able to upgrade...
In any case just find the code in anaconda that opens the dialog
saying that it will reboot, and change it, to let the user continue
the setup.
Comment 3 Michael Fulbright 2003-05-13 12:33:02 EDT
If there is a problem mounting filesystems then the user needs to resolve the
issue before an upgrade can continue.  It was decided it is best to not let
users proceed at this point.
Comment 4 Marco Baldi 2003-05-14 09:12:32 EDT
but what if the filesystem is on a removable drive and the drive is unavailable
at the time of the upgrade?

Note You need to log in before you can comment on or make changes to this bug.