Bug 906315 - API documentation for system.searchByName contains link which does not work
API documentation for system.searchByName contains link which does not work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
550
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Tomáš Kašpárek
Matej Kollar
:
Depends On:
Blocks: sat560-api
  Show dependency treegraph
 
Reported: 2013-01-31 07:56 EST by Jan Hutař
Modified: 2013-10-01 17:45 EDT (History)
5 users (show)

See Also:
Fixed In Version: spacewalk-java-2.0.2-31-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:45:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-01-31 07:56:59 EST
Description of problem:
API documentation for system.searchByName() contains link with text "http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Pattern.html" which does not work as it is interpreted as relative uri.


Version-Release number of selected component (if applicable):
spacewalk-java-1.7.54-111.el6sat.noarch


How reproducible:
always


Steps to Reproduce:
1. Go to https://<fqdn>/rhn/apidoc/handlers/SystemHandler.jsp#searchByName
2. Attempt to click to the link in the text


Actual results:
Link have text:
  http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Pattern.html
but href is:
  https://<fqdn>/rhn/apidoc/handlers/%5C%22http://java.sun.com/j2se/1.4.2/docs/api/java/util/regex/Pattern.html%5C%22


Expected results:
Link should work or should not be there.
Comment 1 Tomáš Kašpárek 2013-04-08 04:24:00 EDT
this issue is already fixed in spacewalk.git:
26a73d62dd9459ed49c5ba7170622338586f873e
edd43b95857fc1600e6dc157955a3065a1635349
Comment 7 Martin Korbel 2013-10-01 10:26:57 EDT
Stage validated with Satellite-5.6.0-RHEL5-re20130926.0-x86_64.

Method: searchByName
Description:
Returns a list of system IDs whose name matches the supplied regular expression(defined by <a href="http://docs.oracle.com/javase/1.4.2/docs/api/java/util/regex/Pattern.html">Java representation of regular expressions</a>)

Parameters:

    string sessionKey
    string regexp - A regular expression

Returns:

    array:
        struct - system
            int "id"
            string "name"
            dateTime.iso8601 "last_checkin" - Last time server successfully checked in
Comment 8 Clifford Perry 2013-10-01 17:40:50 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.