Bug 906383 - [vdsm] [setupNetworks] Error while attaching non-VM network to interface on Fedora 18
[vdsm] [setupNetworks] Error while attaching non-VM network to interface on F...
Status: CLOSED NEXTRELEASE
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Kenigsberg
Haim
network
:
Depends On:
Blocks: ovirt-3.2-release
  Show dependency treegraph
 
Reported: 2013-01-31 09:46 EST by Mike Kolesnik
Modified: 2014-01-12 19:56 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-23 17:59:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
VDSM log (10.47 MB, text/x-log)
2013-01-31 09:46 EST, Mike Kolesnik
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11621 None None None Never
oVirt gerrit 11680 None None None Never

  None (edit)
Description Mike Kolesnik 2013-01-31 09:46:59 EST
Created attachment 690966 [details]
VDSM log

Description of problem:
Ran setupNetworks adding a network, getting failure that the ifcfg file for the host's interface doesn't exist.


Version-Release number of selected component (if applicable):


How reproducible:
100%


Steps to Reproduce:
1. Run setup networks from REST API or UI, attaching a network to an interface
2.
3.
  
Actual results:
Exception in log:
Thread-22::ERROR::2013-01-31 14:58:06,073::BindingXMLRPC::932::vds::(wrapper) unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/BindingXMLRPC.py", line 918, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/BindingXMLRPC.py", line 367, in setupNetworks
    return api.setupNetworks(networks, bondings, options)
  File "/usr/share/vdsm/API.py", line 1215, in setupNetworks
    supervdsm.getProxy().setupNetworks(networks, bondings, options)
  File "/usr/share/vdsm/supervdsm.py", line 81, in __call__
    return callMethod()
  File "/usr/share/vdsm/supervdsm.py", line 72, in <lambda>
    **kwargs)
  File "<string>", line 2, in setupNetworks
  File "/usr/lib64/python2.7/multiprocessing/managers.py", line 773, in _callmethod
    raise convert_to_error(kind, result)
IOError: [Errno 2] No such file or directory: '/etc/sysconfig/network-scripts/ifcfg-p1p1'



Expected results:
Network should be set up on the interface


Additional info:
Comment 1 Mike Kolesnik 2013-01-31 09:53:01 EST
Seems to be happening for non-VM networks only
Comment 2 Dan Kenigsberg 2013-02-01 03:40:34 EST
it is time that we handle initially-missing ifcfg-nic files.

as a workaround, you can pre-create the relevant /etc/sysconfig/network-scripts/ifcfg-p1p1 (I think that even an empty file would be enough).
Comment 3 Dan Kenigsberg 2013-04-23 17:59:38 EDT
Fixed in ovirt-3.2.

Note You need to log in before you can comment on or make changes to this bug.