Bug 906400 - [abrt]: BUG: sleeping function called from invalid context at mm/slub.c:925
[abrt]: BUG: sleeping function called from invalid context at mm/slub.c:925
Status: CLOSED DUPLICATE of bug 906296
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:7951f05f0c0770bde6729826ee6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-31 10:10 EST by Clyde E. Kunkel
Modified: 2013-01-31 10:35 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-31 10:35:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clyde E. Kunkel 2013-01-31 10:10:40 EST
Description of problem:
boot system

Additional info:
BUG: sleeping function called from invalid context at mm/slub.c:925
in_atomic(): 1, irqs_disabled(): 0, pid: 1526, name: Xorg
2 locks held by Xorg/1526:
 #0:  (&rdev->exclusive_lock){.+.+.+}, at: [<ffffffffa00eba89>] radeon_cs_ioctl+0x39/0xa10 [radeon]
 #1:  (&(&bdev->fence_lock)->rlock){+.+.+.}, at: [<ffffffffa0071d67>] ttm_bo_move_accel_cleanup+0x57/0x330 [ttm]
Pid: 1526, comm: Xorg Not tainted 3.8.0-0.rc5.git2.1.fc19.x86_64 #1
Call Trace:
 [<ffffffff8109f899>] __might_sleep+0x179/0x230
 [<ffffffff811b115e>] kmem_cache_alloc_trace+0x4e/0x300
 [<ffffffffa0071ee3>] ? ttm_bo_move_accel_cleanup+0x1d3/0x330 [ttm]
 [<ffffffffa0071ee3>] ttm_bo_move_accel_cleanup+0x1d3/0x330 [ttm]
 [<ffffffffa00d5912>] radeon_move_blit.isra.7+0xc2/0x160 [radeon]
 [<ffffffffa00d6130>] radeon_bo_move+0xb0/0x200 [radeon]
 [<ffffffffa006fed5>] ttm_bo_handle_move_mem+0x275/0x640 [ttm]
 [<ffffffffa0070909>] ? ttm_bo_mem_space+0x179/0x360 [ttm]
 [<ffffffffa0071117>] ttm_bo_move_buffer+0x127/0x150 [ttm]
 [<ffffffffa0074eed>] ? ttm_eu_list_ref_sub+0x3d/0x60 [ttm]
 [<ffffffffa00711e2>] ttm_bo_validate+0xa2/0x130 [ttm]
 [<ffffffffa00d7379>] radeon_bo_list_validate+0x79/0xc0 [radeon]
 [<ffffffffa00ebda4>] radeon_cs_ioctl+0x354/0xa10 [radeon]
 [<ffffffffa001c321>] drm_ioctl+0x501/0x5c0 [drm]
 [<ffffffffa00eba50>] ? radeon_cs_finish_pages+0xf0/0xf0 [radeon]
 [<ffffffff811dff05>] do_vfs_ioctl+0x305/0x530
 [<ffffffff811ebe5c>] ? fget_light+0x3ac/0x520
 [<ffffffff811e01b1>] sys_ioctl+0x81/0xa0
 [<ffffffff816e0919>] system_call_fastpath+0x16/0x1b
Comment 1 Yanko Kaneti 2013-01-31 10:35:35 EST

*** This bug has been marked as a duplicate of bug 906296 ***

Note You need to log in before you can comment on or make changes to this bug.