Bug 90647 - ipt_MASQUERADE has bogus dependancy to ipchains.o
ipt_MASQUERADE has bogus dependancy to ipchains.o
Status: CLOSED DUPLICATE of bug 98241
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
alpha 3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-11 17:42 EDT by Pekka Pietikäinen
Modified: 2007-04-18 12:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Pietikäinen 2003-05-11 17:42:28 EDT
Description of problem:

loading the ipt_MASQUERADE module with modprobe fails with the following error
with 2.4.20-1.1988 (UP athlon)

/lib/modules/2.4.20-1.1988/kernel/net/ipv4/netfilter/ip_conntrack.o:
init_module: Device or resource busy
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-1.1988/kernel/net/ipv4/netfilter/ip_conntrack.o: insmod
/lib/modules/2.4.20-1.1988/kernel/net/ipv4/netfilter/ip_conntrack.o failed
/lib/modules/2.4.20-1.1988/kernel/net/ipv4/netfilter/ip_conntrack.o: insmod
ipt_MASQUERADE failed

Looking at the reason why it doesn't load the following dependancy is found
(ie. it tried to load ipchains.o, which fails since ip_tables is loaded)

/lib/modules/2.4.20-1.1988/kernel/net/ipv4/netfilter/ipt_MASQUERADE.o:/lib/modules/2.4.20-1.1988/kernel/net/ipv4/netfilter/ip_tables.o
\
        /lib/modules/2.4.20-1.1988/kernel/net/ipv4/netfilter/ip_conntrack.o \
        /lib/modules/2.4.20-1.1988/kernel/net/ipv4/netfilter/ipchains.o

In a self-compiled 2.4.21-rc2-ac1 (just about identical kernel config
in the networking side) the dependancy is 

/lib/modules/2.4.21-rc2-ac1/kernel/net/ipv4/netfilter/ipt_MASQUERADE.o:
/lib/modules/2.4.21-rc2-ac1/kernel/net/ipv4/netfilter/iptable_nat.o \
        /lib/modules/2.4.21-rc2-ac1/kernel/net/ipv4/netfilter/ip_tables.o \
        /lib/modules/2.4.21-rc2-ac1/kernel/net/ipv4/netfilter/ip_conntrack.o

and everything works, so does 2.4.20-9. Nuking ipchains.o and ipfwadm.o in
2.4.20-1.1988 makes it work as well.
Comment 1 Philip Kelley 2003-05-16 11:43:02 EDT
fix:

change modules dependencies from

/lib/modules/2.4.20-1.1992smp/kernel/net/ipv4/netfilter/ipt_MASQUERADE.o:
/lib/modules/2.4.20-1.1992smp/kernel/net/ipv4/netfilter/ipchains.o \
        /lib/modules/2.4.20-1.1992smp/kernel/net/ipv4/netfilter/ip_conntrack.o \
       /lib/modules/2.4.20-1.1992smp/kernel/net/ipv4/netfilter/ip_tables.o

to

/lib/modules/2.4.20-1.1992smp/kernel/net/ipv4/netfilter/ipt_MASQUERADE.o:
/lib/modules/2.4.20-1.1992smp/kernel/net/ipv4/netfilter/iptable_nat.o \
        /lib/modules/2.4.20-1.1992smp/kernel/net/ipv4/netfilter/ip_conntrack.o \
       /lib/modules/2.4.20-1.1992smp/kernel/net/ipv4/netfilter/ip_tables.o
Comment 2 Alexandre Oliva 2003-06-17 14:15:18 EDT
Still present in 2.4.20-20.1.2013.nptl
Comment 3 Gerald Teschl 2003-06-28 14:48:07 EDT
I just compiled 2.4.21 + acpi + swsusp and it has the same problem. I am using
the same config file (execpt for acpi turned on), so either this is a config
problem or it is in one of the patches 600 or above (I removed all patches
before 600 to make swsusp happy)
Comment 4 Pekka Pietikäinen 2003-07-22 08:29:00 EDT
Same bug has been reported as a public bug later -> make this one public and a
duplicate of that one

*** This bug has been marked as a duplicate of 98241 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:52:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.